NCC static DHCP reservation not working

Options
MartinTat
MartinTat Posts: 3
First Anniversary First Comment
edited January 4 in Nebula

The clients do not receive the IP address assigned to the MAC-address in the static DHCP table. They receive an address from the IP pool. As a workaround interface LAN1 in DHCP setting is configured with DHCP relay to my synology NAS with package DHCP-Server is used. Works fine an easy.

Interface VLAN31 in the same port group worked fine with the static DHCP table configured at the local lan settings for more than one year. But now the clients get adresses out of the IP pool. Cleaning, deleting the whole static DHCP table would probabely work. This i did when starting with NCC years ago. But the table in the interface setting can not be imported or exported and the editing with scrolling left and right in the narrow window is very uncomfortable.

Why is the DHCP list reservation so sensitive in NCC?

My Setup:

NSG100 security gateway, switches GS1920, GS1350, GS1915 and APs NWA1123-AC Pro, NWA110AX in my network.

Configuration with nebual cloud. Site-wide > Configure > Security gateway > Interface addressing

Interface LAN1: 10.111.108.1/255.255.252.0 DHCP Server,
IP pool start: 10.111.108.101, size 99 → changed to Relay IP of Synology NAS(=working fine)

Interface VLAN31: 10.111.100.1/255.255.252.0 DHCP Server,
IP pool start: 10.111.103.11, size 99

Any idea or solutions? So far I couldnt find any hints in the community to solve my problem. Thanks in advance!

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,889  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 4
    Options

    Hi MartinTat,

    I did a local test:

    1. Connect my PC to NSG. It gets 192.168.1.102.
    2. Set static DCHP binding 192.168.1.10 with my PC's MAC address in the static DHCP table.
    3. Replug my PC, and my PC gets 192.168.1.10.

    May I know if you try to use the cmd command "ipconfig /renew" but still cannot get the correct DHCP IP address? And was the NSG's configuration status up to date when your client got the DHCP IP address?

    If yes, could you enable zyxel support access in the help > support request page for me to check?

  • MartinTat
    MartinTat Posts: 3
    First Anniversary First Comment
    Options

    Hi Melen,
    thanks for the quick reply! Support access is enabled.

    1. I tested with a Laptop on switch GS1915.
      Port 8: VLAN31, Port Group1
      Port 10: VLAN100, Port Group2
      Ip change is working quick and immediately. Even without the need of "ipconfig /renew".

      But i nocticed as follows:
      a) Laptop does not geht IP of static DHCP table.
      b) Laptop does not geht IP in range of actual IP range. Its getting an address out of the pool i had in the past and not the one i changed about 2 weeks ago.
      eg. VLAN31 was changed
      old 10.111.100.1/255.255.254, DHCP Pool 10.111.101.101, size ? 99
      actual 10.111.100.1/255.255.252, DCP Pool 10.111.103.11, size 140
    2. I also changed IP of Port Group2 from 192.168.34.1 to 192.46.44.1. Still i get IP eg 192.168.34.13 from old DHCP range.
    3. I connected all Switches and APs to site or removed them from current site.
    4. I rebooted NSG100



  • Zyxel_Melen
    Zyxel_Melen Posts: 1,889  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @MartinTat,

    Thanks for the privilege. After checking, I found that the NSG has some bad configurations in the DHCP setting part. This caused the Nebula push configuration failure. Please take your time to remove the device from your site and add it back or press the reset button for 10 seconds to erase the bad configuration. This can resolve this problem and get the correct configurations.

    P.S. The latest firmware of NSG can prevent this problem. However, if this problem occurred before the firmware upgrade, the firmware cannot fix this problem.

  • MartinTat
    MartinTat Posts: 3
    First Anniversary First Comment
    Options

    Hy Melen,

    the bad configuration could be solved by removing it from the site. Ok
    (Great and easy way instead pushing reset !)

    1. After that the before changed network range and the additional added network with an other VLAN worked.
    2. The static DHCP table still did not work!
      I had to clear the whole static DHCP table line by line. Also addresses which worked fine for month before. Also removing from site and bringing it back from site did not work.
      At least i had to clear all static DHCP table addresses and removed the NSG again from site and added it to site again.
      Only then the static DHCP table assign worked again.

      As I have done dozens of times in the past, I had to repeatedly remove all entries in the static DCHP list and then set up the list again. (Reset was not necessary in the past).
      Hopefully the list will now work longer. Because it is always very tedious when an entry is added to a previously functioning list and suddenly the whole list no longer works.
      In addition, you always have to scroll left and right in the list with the three entries MAC address, IP and naming for each assignment. It would be nice if this were possible without scrolling left/right or with an import/export.
      That's why I also switched to DHCP assignment via relay of the Synology NAS with one interface because this works more conveniently and reliably.

    Nevertheless, many thanks for the help, after days of trying on my part!!!

Nebula Tips & Tricks