Ubiquiti Cloud key G2 plus not being able to connect to internet with Zyxel router


I have fiberoptic internet at home and my ISP provided me with a Zyxel T-56 modem/router.

I have connected an Ubiquity Cloud key g2 plus to it that is simply unable to connect to the internet. Somehow the Zyxel router just doesn't give it the data it needs to connect to the internet.

My network is working fine with pc's and laptops, they all connect to the internet fine. Connecting the cloud key to other people's networks and to a different router at home also works fine. In those cases the cloud key is able to connect to the internet perfectlyy fine

The problem only start whenever the cloud key is connected to the Zyxel modem/router. I've already tried a static IP based on the mac address of the device and setting the cloud key to the static ip, but that also doesn't work.

I've already tried different ports on the router, different cables, resets of both the router and the cloud key, it all doesn't solve anything.

There are many posts in Dutch forums of people who have the same modem/router from the ISP who tried connecting the cloud key to the Zyxel and they all run into the same problem with the Zyxel router. They cannot connect to the internet. People with Wiim pro's are also experiencing the same issues, so it's 100% the blame of the router these devices cannot connect to the internet.

Does anyone know how to solve this?

P.S. why is it impossible for me to open a support ticket with this company? I get a message saying I need to get in touch with my ISP and cannot contact Zyxel. That's ridiculous. My ISP didn't produce this device, nor did they write any code or firmware for it. If there's a problem, they cannot fix it. There's a problem with the Zyxel device that I would like to address with someone from support who built the device, not through my ISP.

All Replies

  • Bonesie85
    Bonesie85 Posts: 2
    First Comment

    anyone? This is a problem with the zyxel. Can anyone from Zyyxel please just contact me? My ISP isn't very helpful, because they don't know what to do about it. I can't seem to contact support directly because of the serial

  • johndoe24
    johndoe24 Posts: 1
    First Comment

    Hi, I have the same exact issue with the Zyxel EX5601-T1. Tried everything, setting a static IP in the cloudkey, updating firmware, reset, still doesn't gain internet access. Only in the recovery mode the cloudkey gets a IP.

    Temporary workaround is to use a second router for the cloudkey and attach that to the Zyxel to get it to work. I will probably switch to a different router instead of my ISP one.

Consumer Product Help Center