NWA50AX VLAN not working

Mexxx
Mexxx Posts: 2
Friend Collector First Comment
edited January 18 in WirelessLAN

I have a NWA50AX and I want 2 VLANS I have set up on my router to pass through the WiFi. I have changed to Standalone management, have configured the 2 VLANs with tags 10 and 20 on the AP (with the wizard) but its not working. I have tagged ports 1 and 4 (which is where the acces point is connected). My VLANs work for my wired connection but the WiFi is not working. A device I connected to one of the SSIDs with the VLAN gets an IP address in the VLAN network but does not connect to the internet, .

I tried checking off Native VLAN 1 and everything went crazy, necessitating a factory reset.

How do I sort this please?

NB: I also have set up an SSID which is working fine

Accepted Solution

  • Mexxx
    Mexxx Posts: 2
    Friend Collector First Comment
    Answer ✓

    Hi @Zyxel_Judy

    Thanks. I got this sorted now. The firewall rules on Opnsense was the culprit as traffic on my LAN, which was were the working SSID was set up on, was allowed by default but not for the VLANs.

All Replies

  • Zyxel_Nami
    Zyxel_Nami Posts: 435  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 19

    Hello @Mexxx

    As you described, the wireless client can obtain an IP address in the VLAN network when connected to the corresponding SSID but is unable to access the internet. You may follow the guidelines on this FAQ to troubleshoot the issue.

    Also, since you mentioned that another SSID is working well, is there any difference in the setting of these two SSIDS?

    Regarding the Native VLAN 1 setting, when it is unchecked, the AP adds the VLAN 1 tag to outbound traffic. Therefore, the uplink device must be configured to handle tagged VLAN 1 traffic to properly receive data from the AP. If the uplink device isn't set up correctly, devices like PCs that typically don't recognize VLANs might face issues accessing the AP's Web GUI.

    Zyxel Nami

  • Mexxx
    Mexxx Posts: 2
    Friend Collector First Comment
    Answer ✓

    Hi @Zyxel_Judy

    Thanks. I got this sorted now. The firewall rules on Opnsense was the culprit as traffic on my LAN, which was were the working SSID was set up on, was allowed by default but not for the VLANs.