NR7101 slow WAN speeds

Hi everyone.

I have bought an NR7101 few weeks ago as a replacement for a Tenda 5G03. Unfortunately the results are quite disappointing and I can't figure out what's wrong.

Today I've collected some data that I would like to share with you, hoping to get better speeds with this router.

I live in Italy and I have a Wind SIM inside the router. My house 300m from the BTS which I can clearly see from my roof and as you can see from the photo, the router is pointed directly towards it.

My bands look good and I can connect to all the available ones on that BTS:

LTE 20, 7, 1

5G 3

The signal strength is obviously great:

So far so good but here it's starting to get weird.

Using the sim within my iPhone, from the roof, pointing towards the BTS, these are the speeds I can get. This is basically the top speed available on the BTS with Wind:

iOS field test confirms I'm getting the same bands connected with the NR7101.

With the NR7101 I can't get my download speeed over 90Mbps and upload speed over 50Mbps.

With my previous indoor router Tenda 5G03 I could easily get speeds around 160-180Mbps, I can't understand why the NR7101 which should be much more powerful and installed in a much better position provides such bad results.

Last piece of information, this is the firmware and modem FW I'm using.

Current Firmware Version: 1.00(ABUV.8)C0

Current LTE Module Version: RG502QEAAAR13A02M4G

I hope someone could help me.

Thank you

Best Answers

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓

    Your LAN speed is?

  • j1mm1
    j1mm1 Posts: 5
    First Comment
    edited January 20 Answer ✓

    Well, now I feel dumb…

    But I can't understand why is that, I am connected to the router directly with my laptop which is equipped with a gigabit eth adapter:

    https://www.intel.com/content/www/us/en/products/sku/82186/intel-ethernet-connection-i219v/specifications.html

    Using the original POE adapter included into the NR7101 box. Is there a way I can force the gigabit LAN on the router settings?

    Thanks again.

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 20 Answer ✓

    I had the same on my connection from the beginning.

    It was due to a bad ethernet cable between the modem and the adapter.


All Replies

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 20

    • 1. Uncheck B20 and check speedtest.
    • 2. Select only 4G and re add B20 and check speedtest again.
  • j1mm1
    j1mm1 Posts: 5
    First Comment

    Thanks Selberg. Here's the result. Pretty much unvaried…

    1.

    2.

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓

    Your LAN speed is?

  • j1mm1
    j1mm1 Posts: 5
    First Comment
    edited January 20 Answer ✓

    Well, now I feel dumb…

    But I can't understand why is that, I am connected to the router directly with my laptop which is equipped with a gigabit eth adapter:

    https://www.intel.com/content/www/us/en/products/sku/82186/intel-ethernet-connection-i219v/specifications.html

    Using the original POE adapter included into the NR7101 box. Is there a way I can force the gigabit LAN on the router settings?

    Thanks again.

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 20 Answer ✓

    I had the same on my connection from the beginning.

    It was due to a bad ethernet cable between the modem and the adapter.


  • j1mm1
    j1mm1 Posts: 5
    First Comment

    Thank you Selberg, I will try to change the cable in the next few days as that will be a tricky job :(

    This was helpful thanks!

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited January 20

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer

    My suggestion is that you take down your modem and connect a short ethernet cable to see if it changes to 1000m/full before you change the cable.

  • j1mm1
    j1mm1 Posts: 5
    First Comment

    Replaced the cable with a CAT7 external cable. That is more like it.

    Thank you for your valuable help!

    I believe we can close the issue :)

Consumer Product Help Center