Vodafone ISP WAN connection - PPPoE to USG20W

HoS
HoS Posts: 7
First Anniversary Friend Collector First Comment

I have an issue almost identical to this case however the solution here has not worked for me:

To summarise, I have a newly connected Vodafone 100mb business fibre connection with a single fixed IP provided by them.
Standard router THG3000. Connecting to WAN port of ONT to WAN port on router.

Vodafone have provided the following credentials and configuration requirements for connecting via 3rd party equipment.
»»»»»
Username: [email protected]
PW: XXXXXXX

Please ensure your router is capable to support VDSL and the following basic configuration is required:

DSL Mode set to using VDSL

PPPoE VLAN tag 101
»»»»»»»»

Using the first time connection with the Vodafone router to confirm activation I was able to pull off the basic IP / DNS / Gateway settings as follows:

Internet
IPv4 Address: (ISP Allocated Fixed IP)
Gateway: (IP assigned by ISP)
Primary DNS IPv4 Address: 90.255.255.90
Secondary DNS IPv4 Address: 90.255.255.254
IPv6 Prefix from DHCPv6
IPv6 Prefix
IPv6 Global Address
IPv6 ULA Address
Disabled
IPv6 Link-Local Address
Primary DNS IPv6 Address
Secondary DNS IPv6 address
Firewall
On
PPP Session Uptime
6 minutes and 37 seconds

I have factory reset the USG 3 times and tried what feels like every permutation of Ethernet, PPP, VLAN, TRUNK, ISP manual entry, ISP using the PPPoE Wizard but every attempt to connect just fails. I'm sure this is something where I'm just not putting the right data in the right field of the right tab. I'm getting confused where an IP should be using the fixed one and when the configuration should be set to automatic and 0.0.0.0

I've tried to follow the advice in the above thread and feel like this solution is really close but no luck for me. I've also tried the step by step on Configuring PPPoE per this knowledge base. If anyone can assist / clarify where I may be going wrong I'd be so grateful.

https://support.zyxel.eu/hc/en-us/articles/360001390334-Firewall-Setting-up-a-VLAN-on-a-WAN-PPPoE-Interface

All Replies

  • HoS
    HoS Posts: 7
    First Anniversary Friend Collector First Comment

  • HoS
    HoS Posts: 7
    First Anniversary Friend Collector First Comment

    Just wanted to close this post but going to add the following potential solution for anyone else who finds themselves with the above issue. I appreciate this is extremely basic but for those who find themselves infrequently having to be the "IT" department but don't do it all day long……

    ISP Gave only Username & Password login credentials
    informed me my static IP address xx.xx.xx.xx was now active.
    I should make sure my existing equipment was set to using VDSL mode & PPPoE VLAN tag 101
    That was literally it.

    Despite numerous resets and attempts to create / stack Ethernet, PPP & VLAN with every combination of IP information as fixed or get automatically I could think of or had seen elsewhere, I finally solved this in the following way:

    From a factory default position:
    Config>Object>ISP Account>
    Picked default entry: WAN_PPPoE_ACCOUNT > Edit

    Configuration:
    Authentication Type:
    Chap/PAP
    User name: (Provided by ISP)
    Password: (Provided by ISP)
    Service Name: (Used my ISP as identifier)
    Compression:
    Off
    Idle Timout: 0


    Next…

    CONFIG>NETWORK>INTERFACE>ETHERNET>wan
    Configured as follows:

    Type: External
    Name: wan
    Port: P2
    Zone: WAN
    MAC Address: xx:xx:xx:xx:xx:xx

    IP Address Assignment: Use Fixed IP Address

    IP Address: 0.0.0.0
    Subnet Mask: 0.0.0.0
    Gateway: (Blank)

    Next…

    CONFIG>NETWORK>INTERFACE>PPP
    Set PPP Interface as follows: (All under System Default entry! No User configuration at all !!)


    Interface Name: wan_ppp
    Base Interface: wan
    Zone: WAN
    Description: (For me I used Vodafone)

    Connectivity: Dial-on-Demand

    ISP Profile: WAN_PPPoE_ACCOUNT
    (Configured in step one before anything else so settings were loaded when this was selected from the options in the drop down).

    IP Address Assignment: Get Automatically

    Saved / applied and highlighted the wan entry then clicked connect and it instantly went green.
    A big thank you to Vodafone for obfuscating the entire process with seemingly erroneous information regarding Vlans and tags. The connection was instant and all from the system default entries.

    Hope this may help someone with similar issues:

  • Zyxel_Jeff
    Zyxel_Jeff Posts: 1,012  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @HoS

    OK, many thanks for your sharing with us😃.

Security Highlight