Android Wi-Fi calling issues - VMG8623-T50B

Jonathan_Tree
Jonathan_Tree Posts: 4
Friend Collector First Comment
edited March 22 in Home Router

I have a customer who has a VMG8623-TG50B for a FTTP connection. Their connection is supplied by TalkTalk Wholesale on the Openreach network.

Issues appear on inbound Wi-Fi calls on their android phones. Outbound calls work fine and the wifi works, but inbound calls the user gets a "Sorry this number is unavailable" message.

I have enabled SIP ALG, reduced the MTU settings on the router and the issue persists.

Any suggestions on how to fix this?

All Replies

  • Liba
    Liba Posts: 107  Ally Member
    First Anniversary 10 Comments First Answer

    It looks like this device support voip. Maybe you have to check and disable voip settings if voip enable.

  • Hi Liba,

    When you say device, do you mean the router or the customer's phone? I've gone through samsung settings with the customer and the Wi-Fi calling works fine when connected to other routers, so I know its not a handset issue and they can do outbound Wi-Fi calling, it is just inbound.

    I also have other customers using android phones and Wi-Fi calling that works well, but they are on a different technology (FTTC) where this customer is on FTTP.

  • tonygibbs16
    tonygibbs16 Posts: 832  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited March 22

    Hello @Jonathan_Tree

    It might be a couple of things, and might even be a firewall issue.

    Who is the Mobile Network Operator? Do they give advice?

    For example, T-Mobile have the following advice https://www.t-mobile.com/support/coverage/wi-fi-calling-on-a-corporate-network

    Kind regards,

    Tony

    PS: WiFi calling uses the 3GPP Generic Access Network (GAN) standards, see https://www.etsi.org/deliver/etsi_ts/143300_143399/143318/15.00.00_60/ts_143318v150000p.pdf and https://en.wikipedia.org/wiki/Wi-Fi_calling

  • Hi @tonygibbs16,

    Thanks for looking at this.


    They are on Lebara mobile and I've searched online and couldn't find any info on this.

    I've already logged into the router and changed the firewall settings to allow UDP ports 500, 4500 and TCP 143 ports, as well as reducing the MTU size and enabling SIP ALG. So confused on this one!

  • tonygibbs16
    tonygibbs16 Posts: 832  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @Jonathan_Tree

    You're welcome.

    You could look at putting PCAPdroid on the smart phone and seeing if you can capture the GAN paging of an incoming call.

    * you should be able to put the captured PCAP file into Wireshark.

    Alternatively, talk to Lebara and see if they can help you. The announcement would suggest that the GAN paging is failing to find the smart phone.

    * If the GAN IPSEC tunnels have set-up ok, then it should work…as long as Lebara don't have a problem themselves.

    I have WiFi calling working through my Zyxel NBG7510 and did not have to turn SIP-ALG on.

    Kind regards,

    Tony

Consumer Product Help Center