NBG7510 MAC filtering not working

edited April 24 in Home Router

Hi I just found out that MAC filtering on the Zyxel NBG7510 router does not work in allow mode. I rebooted the NBG7510 and was still able to connect every device I tried. Is it possible to get a firmware update or something similar? Have I missed some important setting to make the filtering work?
Additional information: Most of the configuration on my router should not be too special but I tried the filtering without any password protection on wifi as I have a device that does not support WPA3 and WPA2 encryption.
Thanks in advance.

All Replies

  • tonygibbs16
    tonygibbs16 Posts: 860  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 25

    Hello @Mathamphetematiker

    Welcome to the forum.

    Can you please say what firmware version is in your NBG7510 at present?

    Is it in Router mode or in AP mode of operation?

    Is MAC filtering on WiFi that you are trying to do?

    V1.00(ABZY.6)C0 is the latest version of firmware, according to https://www.zyxel.com/us/en-us/support/download?model=nbg7510

    Kind regards,


  • Mathamphetematiker

    Its the last version of the firmware that you mentioned, I updated it when the problem occured yesterday but it didnt solve it.

    Its in the router mode und I try to set up MAC filtering on WIFI to only give permission to access the network to the mentioned devices in allow mode.

  • Zyxel_Jerry
    Zyxel_Jerry Posts: 1,128  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @Mathamphetematiker

    Do you mean the MAC filter in Wireless settings?
    Could you send us the configuration file and the login password in private message, we would like to check if there is any difference in the configuration.

    The MAC filter in Wireless settings should work on this firmware.

Consumer Product Help Center