Why can't some clients connect to SSID after enabling MLO?

Zyxel_Judy
Zyxel_Judy Posts: 1,352  Zyxel Employee
Zyxel Certified Network Engineer Level 2 - Nebula Second Anniversary Zyxel Certified Network Engineer Level 1 - Switch Zyxel Certified Network Engineer Level 1 - Nebula

Scenario

After enabling Multi-Link Operation (MLO), certain devices cannot connect to my 2.4GHz/5GHz/6GHz SSID. Disabling MLO resolves the connectivity issue.

Root cause

When an SSID with MLO is enabled on 6GHz, the SSID security is automatically converted to WPA3-related settings as per specifications. Some devices, especially IoT devices, that don't support WPA3-related settings cannot connect to this SSID.

Solution

Create a new SSID with suitable security settings for IoT and other devices that don't support WPA3.

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