USG110 DNS Configuration

TWCC Posts: 2
First Comment
edited April 2021 in Security


I'm trying to setup my USG110 as a DNS Server / Forwarder, in order to give names to the LAN devices and resolve Internet Names.

This is how I configured the router, that is

DHCP (Interface -> Ethernet -> lan1):

IP Pool Start Address:, Pool Size: 200

First DNS Server (Optional): ZyWALL

Second DNS Server (Optional): None

Third DNS Server (Optional): None

Default Router: lan1 IP

DHCP Option 42 (IP):,

DHCP Option 15 (TEXT): lan.local

Enable IP/MAC Binding: YES

Enable Logs for IP/MAC Binding Violation: YES

(I Have some MAC addresses bounded with specific IP addresses)

Host Name (System -> Host Name)

System Name: router

Domain Name: lan.local

DNS (System -> DNS)

Address/PTR Record table with some pairs of FQDN / IP Address.

Domain Zone Forwarder Servers:

lan.local, Private,

*, Public,

*, Public,

The computer attached to the network correctly gets the DHCP information, with the correct domain name (lan.local), and surfs the Internet.

But if I try to ping some devices using the name, nothing is resolved. I tried to ping "router" and "router.lan.local", as well as other devices i put in the Address/PTR Record table, and I can't reach them, ping tells me that the hosts cannot be found.

What I'm doing wrong?

Thank you!


All Replies

  • PeterUK
    PeterUK Posts: 2,699  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Did a test on my ZyWALL 110 with win10.local at all worked fine

    I didn't have to add lan.local or

    Domain Zone Forwarder Servers

    lan.local, Private,

    As long as the device thats pings win10.local has DNS to ZyWALL IP in my case it should just work.

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 1,444  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @TWCC

    Welcome to Zyxel community.😀

    I did the same test as your settings. It works at my lab.

    Can you try it again and capture packets on your pc during the test?

    Send me the packets trace via private message.

    1)  Lab USG DNS setting: Add 2 DNS A record.

    2) Lan host IP configuration: The lan host get domain suffix from USG.

    3) Ping target host: Even ping without domain suffix , the windows auto add domain suffix to host name when I ping to target host. It can be resolved without issue.

  • TWCC
    TWCC Posts: 2
    First Comment

    It appears that now everything is working properly, and the configuration has always been correct.

    I've just done a reboot.

    It has been simple, but I'm a bit upset, because it's a very Windows style behaviour. I can accept it from my cheap home modem router, but not from a device that must be always running and support any type of configuration variation without issues.

    Anyway, thanks to everyone! I've really appreciated your help!


  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 1,444  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @TWCC Good to hear that the issue is solved.😄

Security Highlight