Adding DNS Forwarders

Ian_Ross_7BS
Ian_Ross_7BS Posts: 2  Freshman Member
edited April 14 in Nebula
Trying to add a DNS Forwarder to a NSG100. Instructions say for all domains type a * and then add your DNS server address (e.g. 8.8.8.8).  As soon as the * goes into the domain box it turns red and you cannot save.  Do others see the same? 

Comments

  • Zyxel_Jonas
    Zyxel_Jonas Posts: 241  Zyxel Employee
    Hi @Ian_Ross_7BS,

    Welcome to Zyxel Community!
    Thanks for reporting this problem, there is some documentation error.
    DNS zone forwarder doesn't support [*], you'll need to input the complete domain name.
    (e.g. aaa-bbb.com)

    Regarding the document, we will have it correctly modify.
    Sorry for the inconvenience.
    Jonas,
    Jonas,
  • Ian_Ross_7BS
    Ian_Ross_7BS Posts: 2  Freshman Member
    Perhaps you could help my understanding here.  If I can't use the * (all domains) identifier then I will need to add an entry for every single domain I may ever need to look up.  This is not practical!  USG's default to allowing the ISPs DNS servers that they pick up either automatically or by manual entry and allowing a look up of any domain to that DNS server.  If there is another way of achieving this then I need to understand.
  • Zyxel_Jonas
    Zyxel_Jonas Posts: 241  Zyxel Employee
    Hi @Ian_Ross_7BS,

    Domain zone forwarder is to input the specific domain name.
    For your scenario, you should use the interface settings to achieve the goal.
    Steps as below:

    1. Go to Security gateway > Configure > Interface addressing, choose which LAN interface and click on the edit button.


    2.  Change DNS server to custom defined and input the DNS server address. Example as figure below.


    Reminder: Remember to click the "Save" button after changing any settings.

    Jonas,
    Jonas,

Nebula Tips & Tricks