NAS542 wird nicht überall im Netzwerk angezeigt

Options
Schandi
Schandi Posts: 6  Freshman Member
edited July 2018 in Personal Cloud Storage
Hallo, habe ein Problem mit der Anzeige des NAS542 in meinem Netzwerk.
Smb1 ist aktiviert und genau da liegt mein Problem. Das NAS wird immer nur auf dem PC angezeigt der als erstes gebootet wurde. Auf diesem Rechner funktioniert dann der Zugriff auch Problemlos. Auf den anderen PCs wird das NAS nicht angezeigt aber Zugriff, z.B. über IP oder Netzlaufwerk klappt ohne Probleme. Die Verbindung wird über LAN oder WLAN hergestellt.
Funktionssuchanbieter-Host und Funktionssuchanbieter-Ressourcenveröffentlichung sind auf automatisch mit verzögertem Start.
Smb1 ist wie gesagt bei W10 aktiviert.
Desweiteren habe ich auch NetBios über TCP/IP aktivieren eingestellt.
Dies habe ich von Microsoft als Workaround gefunden.
Router Asus RT-AC87U wurde auf Werkseinstelltung zurückgesetzt und neu konfiguriert.
Aber ich bekomme es einfach nicht hin, dass das NAS auf allen Geräten angezeigt wird. Habt Ihr hier noch einen Vorschlag was ich testen könnte?

#NAS_July

Accepted Solution

«1

All Replies

  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited July 2018
    Options
    That smells like a master browser problem. Who is the master browser in both cases?
    How to Determine the Master Browser in a Windows Workgroup
    (Don't know if that still applies for W10).


  • Schandi
    Schandi Posts: 6  Freshman Member
    Options
    Hello, yes only the Master Browser can see the NAS. I testet with stopped Dienste: Computerbrowser, activated Dienst. I test it with NAS can set to Master Browser. Everytime the same: Only Master Browser see the NAS
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    The NAS is always on, I suppose?

    You can try if it helps to make it master browser.

    Edit /etc/samba/smb.conf, under the [global] tag add
    domain master = yes
    preferred master = yes
    local master = yes
    os level = 200<br>
    Then restart samba:
    /etc/init.d/samba.sh restart<br>
    Do not restart the NAS. The file /etc/samba/smb.conf is volatile. And do not change any share related setting in the webinterface, a new smb.conf might be generated.

    Is your router capable to run samba?
  • Schandi
    Schandi Posts: 6  Freshman Member
    Options
    Can you please explain to me more exactly where I have to enter this?
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    ? What is unclear about 'in /etc/samba/smb.conf , under the tag [global]'?
  • Schandi
    Schandi Posts: 6  Freshman Member
    Options
    I have never work outside of webinterface. Login with SSH is no problem (putty), but now i have no idea who modify smb.conf. Sorry
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Try WinSCP
  • Schandi
    Schandi Posts: 6  Freshman Member
    Options
    Many thanks for your support! All is ok. NAS is on all PCs visible.
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I wrote a Tweaks plugin to handle the volatile nature of this patch. Do you want to test it?
  • Schandi
    Schandi Posts: 6  Freshman Member
    Options
    Yes, sure!

Consumer Product Help Center