[VMG8825-B50B] USB port runs slow on file transfer



  • Tremors
    Tremors Posts: 7  Freshman Member
    edited March 2019
    Hi AAAAL.
    Just for information, my external HDD is a 1 TB USB 3.0 Toshiba DTB310. My PC is connected through Ethernet cable to the router, but the transfer rate copying files to the hdd is as low as 500/600 Kbps. Is it a compatibility problem? I might try with a different hdd.
    Now that I've got the last firmware b7_20180810, I hoped it was solved but it's not the case actually.
    AAAAL Posts: 125  Ally Member

    Hi Haikoan,

    We do not have a compatibility list for USB connection, it has too many various kinds.
    I use my Transcend series and WD HDD with USB3.0 for connecting.
  • stefano_sb
    stefano_sb Posts: 14  Freshman Member
    Hi, what filesystems do you use? NTFS? exFAT?
  • txmxer
    txmxer Posts: 4  Freshman Member
    Hi, new here.  Sorry to dredge up an old thread, but it's related to my issue and I have a work around that's great.  Connecting my USB 3.0 MyBook to the NAS USB ports resulted in slow transfers of 10-20 MB/s as well as errors on some files that I couldn't transfer.  I tried to use the copy/sync function and using a Web interface and the transfer speeds were still painful trying to backup TB's of data. 

    I moved the USB drive to my computer's USB 3.0 port and now I'm seeing 100 MB/s transfers over LAN using Windows Explorer copy function.

    Yes, I'm thrilled with that.  But not satisfied that I can't do the same with the local USB ports on the NAS. 

    The USB drive is EX-FAT, but from all I've read the format has only marginal performance differences.  The ports on the NAS are working like USB 2.0 IMO. 

    Hope this helps if someone else is running in to this issue.
  • Hummel
    Hummel Posts: 212
    First Comment Friend Collector Third Anniversary
     Master Member
    edited February 2020
    Suggest you to create a new post to ask your question because VMG8825-B50B is not a NAS but a CPE (router). Since your question is about NAS not CPE, I think this is not a correct post for your problem.
  • sparks
    sparks Posts: 1
    Hi AAAAL

    I have a new Zyxel EMG3525-T50B and can confirm the same issue. The transfer rate via LAN/WIFI is ridiculously slow when uploading to the network drive. I have tried multiple setting and recommendations on the Windows 10 OS as well as different clients, all with the same result. I am using a Transcend 3TB HDD USB3.0 like suggested above and still have this issue. It seems clear this is a router problem as I have not experienced this on any of my previous routers. All other functions seem to work great thus far, with a solid media sharing performance - all of which is pointless if i cannot upload to the HDD without having to plug it directly into the client. Please explore this further and advise of the solution, or implement as a bug fix in the upcoming firmware releases? 
  • Hummel
    Hummel Posts: 212
    First Comment Friend Collector Third Anniversary
     Master Member
    How do you run the test? What is your test topology?
    And what is the test result you got?

Consumer Product Help Center