NBG6515 bricked after firmware upgrade.

oskarsu89
oskarsu89 Posts: 3  Freshman Member
edited March 2019 in Home Router
Hi, 

It seems that my NBG6515 router has become unusable after latest firmware upgrade and I cannot get it to work anymore. Currently only the power LED comes on, I tried using the reset button following the procedure in the user guide, didn't help. Router is not working in any mode (repeater/router/AP). Plugging an Ethernat cable from router to PC, connection light comes ON but no IP address is assigned to PC, tried assigning address to PC in the range of 192.168.1.x manually and couldn't ping the router on either .1 or .2 address.
Was wondering if there is another procedure to restore the firmware? maybe via USB or using some application that can access the router over some different protocols?
Please help.

#Router_Mar_2019

All Replies

  • Hill
    Hill Posts: 145  Ally Member
    I think it may HW problem, if your location is in Europe. You can submit a request about RMA (Return Material Authorization) from the link. (https://support.zyxel.eu/hc/en-us/requests/new)
  • oskarsu89
    oskarsu89 Posts: 3  Freshman Member
    I can see on other similar posts that members have been messaged privately with what appears to me some kind of instructions to unbrick the router. Can someone do the same here please? 
  • Zyxel_Steven
    Zyxel_Steven Posts: 247  Zyxel Employee
    @oskarsu89,
    NBG6515 hasn't any recovery tool/way. If after reset NBG6515 and still cannot access it, you need to contact with ZYXEL support team of your local for assistance.
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!