VMG1312-b10d firmware upgrade error

2»

All Replies

  • Solo01
    Solo01 Posts: 11  Freshman Member

  • Zyxel_Support_CPE
    Zyxel_Support_CPE Posts: 187  Zyxel Employee
    Hi Solo01, 

    To check your screenshot, you selected to "zip" file. You must unzip that package and then select to “V513AAVF12C0.bin”. Please try again, thanks.
  • Solo01
    Solo01 Posts: 11  Freshman Member
    thanks @Zyxel_Support_CPE i managed to redownload the file from a different source and unzip properly the file and succeded!! :)
  • vmg1312
    vmg1312 Posts: 1
    Same here. Today Downloaded the .bin file from both server 1 and server 2 but get same error when uploading the file to the Zyxel device. (failed....illegal image). Please fix it Zyxel ! :(
  • Zyxel_Support_CPE
    Zyxel_Support_CPE Posts: 187  Zyxel Employee
    Hi vmg1312,

    To double check the .bin on ftp site, it has no problem. May I know  which browser and its version you use? Did you clean cookie or find another PC/laptop to try again?  

  • I have this same issue @Zyxel_Support_CPE. I am looking to move from V5.13(AAXA.5)C0 to V5.13(AAXA.10)C0 but get the "failed illegal image error". I have tried different browsers, cleared cookies, tried incognito mode. I have also tried taking  AAXA.5 to AAXA.7 first but it still fails. I am using .bin files from the Zyxel FTP site. Can you please advise on what the solution to this is...
  • Hummel
    Hummel Posts: 212
    First Comment Friend Collector Third Anniversary
     Master Member
    edited November 2019
    @manzaboy,
    Can you describe how you upgrade the firmware?
    Do you select the correct V513AAXA7C0.bin or V513AAXA10C0.bin file to upgrade?
    I tried it with my VMG1312 to upgrade it from V5.13(AAXA.5)C0 to V5.13(AAXA.7)C0 and from V5.13(AAXA.5)C0 to V5.13(AAXA.10)C0 without any problem.
  • I have the same issue. Very frustrating.
    Model VMG3625-T20A.
    Download firmware image from: https://www.zyxel.com/support/download_landing/product/vmg3625_t20a_13.shtml?c=gb&l=en&pid=20161116160002&tab=Firmware&pname=VMG3625-T20A

    Extract zip, select 530ABIE5C0.bin file, and then boom, get error:
    "Image uploading failed. The selected file is an illegal image."
    Even tried previous versions, d
  • Hummel
    Hummel Posts: 212
    First Comment Friend Collector Third Anniversary
     Master Member
    edited May 2020
    @Router Dude
    I know that you can't upgrade firmware with different firmware id.What is your current firmware version? Is it similar with 530ABIE5C0?
  • tonygibbs16
    tonygibbs16 Posts: 506
    25 Answers First Comment Friend Collector Second Anniversary
     Guru Member
    Hi @Zyxel_Support_CPE,

    I have been getting this same error when I have been trying today to do the upgrade.

    Initially I was using the chrome-based version of Edge, and got the error everytime.

    Then I used Firefox, and managed to get the VDSL router upgraded from 5.11(AAXA.4)C0 to 5.13(AAXA.7)C0, then I could get no further using Firefox.

    Then I went to using Chrome, and got the same error message.

    Then I went back to the Chrome-based version of Edge, and have managed to get it upgraded to 
    5.13(AAXA.10)C0


    I will need to learn the new user interface, as I really liked the connectivity map that showed me which devices were connected in a picture.

    I got the firmware images from your website and from ftp://ftp.zyxel.com/VMG1312-B10D/firmware/ 

    My reason for doing the firmware upgrade at all was that 5.11(AAXA.4)C0 had an issue for me, whereby the WiFi would suddenly stop working for now reason, with the WiFi light out, and no message in the log file.

    I like your product and have used it for a while.

    I hope that this is helpful.

    Kind regards,
         Tony

Consumer Product Help Center