Unable to login on GS1900-24E after upgrade to GS1900-24E_2.50(AAHK.0)

Warnis
Warnis Posts: 4  Freshman Member
edited April 14 in Switch
After upgrading my GS1900-24E with the formware GS1900-24E_2.50(AAHK.0) I am no longer able to login. Before the upgrade the switch had the default user and password admin/1234. After the upgrade I cannot login anymore. Tried a reset, but it does not help. I keep getting "The user name or password is incorrect."


#Biz_Dec_2019

Best Answers

  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    Accepted Answer
    Hi Warnis

    We have tried to upgrade our GS1900-24E from FW 2.40 patch 2 to FW 2.50 in our local test.
    However, we still can't replicate the issue you have encountered.
    In our local lab, we have changed the password.
    After upgrading firmware, the switch can still be logged in.
    Also, we have tried to reset switch to default and it can be logged in by default account and password.
    Therefore, could you help us to provide a video about your process of resetting switch to default?
    The video should include how you press the reset button.
    Thanks for your cooperation in advance

    Zyxel_Derrick


  • Warnis
    Warnis Posts: 4  Freshman Member
    edited December 2019 Accepted Answer
    After another reset the switch no longer answered on 192.168.1.1, not even on ping. After a while I found it on 192.168.1.47, and even managed to login with admin/1234. After logging in I could see that it had changed from static addressing (192.168.1.1) to DHCP, why it now had been assigned a dynamic addess. 

    Since I now was able to login, I could set everything the way I wanted. Why did it automatically change to DHCP? Will that happen again if I reset?

    Regards
  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    edited December 2019 Accepted Answer
    Hi Warnis

    Glad to hear that you can login switch
    The current behavior of switch is that when you reset switch or use it for the first time, switch will try to discover if the network environment has dhcp server or not.
    If yes, switch will use the ip address that assigned by server.
    If no, switch will use 192.168.1.1 as its ip address
    Thanks

    Best regards,
    Zyxel_Derrick
«1

All Replies

  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    Hi Warnis

    Welcome to Zyxel Community
    Normally, after upgrading firmware and rebooting, switch will run start-up config.
    If the password had not been changed and saved before, normally it can login with default account and password.
    Also, you mentioned that you had tried to reset but doesn't work.
    According to user guide P.34, you have to press the button at the front panel for six seconds until the SYS LED begins to blink and then release.
    For more details about how to reset to default config, you can download the user guide in the link below and refer to it
    Hope it helps

    Best regards,
    Zyxel_Derrick
  • Warnis
    Warnis Posts: 4  Freshman Member
    Hi,

    thank you for your quick response. 

    The reset itself seems to have worked. The IP address
     was reset to 192.168.1.1, but I can no longer login when browsing there. I just get "The user name or password is incorrect." when trying to log in with admin/1234, which worked perfectly fine before the upgrade.
  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    Hi Warnis

    May I know what kinds of browsers you use?
    Also, have you ever tried to use another browser or clear the browser's cache?
    If yes, the result is the same?

    Zyxel_Derrick
  • Warnis
    Warnis Posts: 4  Freshman Member
    edited December 2019
    Hi,
    I have used Chrome on windows, IE on windows, Chrome on Android and Samsung browser on Android. Same result everywhere. What should I do?
  • Good morning. We have the same issue. We have update the GS1900 to to the 2.5 version but we tried to return to the 2.4 version becouse of the RSTP didn`t work (this is other question) and the we could not access to the switch. It seems as the user is not recognized.The zyxel switches (6 units) are the core in our network and we can not update them. Thank you for your assistance.
  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    Hi rmarmol80

    This is the known issue for GS1900 listed in the release note that downgrade from V2.50 to V2.40 and below versions will cause admin account unable to login. This is due to password authentication algorithms are enhanced for vulnerability issues and is not backwards compatible.
    Therefore, the only way to login switch after downgrading is to reset switch to default and use default account and password to login.
    Thanks

    Best regards,
    Zyxel_Derrick

  • Good morning and thanks your your answer. We have another issue when we try to upgrade the GS1900. We have 5 switches with the 2.4 version. All of them are connected with LAG to create a redundancy among them. To start with the upgrade, we configure first one of them. We dont know why, but the switch goes down due to the spanning tree protocol and we must disconnect one of the redundancy way. The problem can be caused due to they are working with different versions? Have you tested if the LAGs can work with different verions (2.4 and 2.5)?

    Best regards.