Zyxel vmg8825-t50 WiFi connection issue

Gniptsaf
Gniptsaf Posts: 2  Freshman Member
edited March 2020 in Smart Home Product
I changed internet provider and the new provider gave me this new router. After installation all my family 4 android smartphones can connect to WiFi smoothly. Instead an Nvidia Shield k1 android tablet refuses to connect. Connection status become "Disabled" or "Saved". I have tried: 1) reboot (both rooter and tablet), 2) reset all network connection (on tablet) 3) reset tablet to factory settings. Still it cannot connect. I have tried to connect it to a smartphone WiFi hotspot and it works, so there must be some problem with the router.
Thanks for your help


#SP_Mar_2020

Accepted Solution

  • Gniptsaf
    Gniptsaf Posts: 2  Freshman Member
    Accepted Answer
    Thank you Hummel,
    sorry I couldn't read your message sooner. Anyway I solved the issue by setting 802.11 mode to "n only" instead of "b/g/n Mixed". It's quite strange. It works also with "b/g Mixed". 
    There is some problem with the "b/g/n Mixed" mode I guess.

All Replies

  • Hummel
    Hummel Posts: 212  Master Member
    edited March 2020
    @Gniptsaf,
    Do you connect to 2.4GHz or 5GHz wireless network?
    Have you tried to disable the WiFi security to not using password and see if your Nvidia Shield k1 android tablet can connect to the router or not?
  • Kora_Hansen
    Kora_Hansen Posts: 1
    Funny, googled VMG8825-t50 Wi-Fi issues as I to have a connection problem with my Nvidia Shield k1 tablet. I will try this. One thing I did was activate Guest Wifi on 2.4 GHz which momentarily fixed my problem
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!