Problem with RandomTools screen?

Options
Aylwin
Aylwin Posts: 2  Freshman Member
Hi,

When I try to use screen I get the following error:
Cannot find terminfo entry for 'xterm-256color'.
This can be caused be the terminfo variable not being set.  But it is:
TERMINFO=/i-data/4f0e4eec/.PKG/RandomTools/share/terminfo
The problem seems to be that there's no entry for xterm-256color.  However, there is one for xterm-color.  So my workaround was simply to create a copy of xterm-color and name it xterm-256color.  Now screen works.

But is this a known issue?  Should it be fixed?  Or did i maybe make a mistake somewhere when installing RandomTools?

-Aylwin

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    But is this a known issue?  Should it be fixed? 

    It is a known issue, in the sense that I know xterm-256color is missing, as someone reported that before. So far it hasn't bitten me, maybe due to the ssh clients I use. The work-around is easy, as you found. You can also put a TERM=xterm in your profile, or something like that.

    Should it be fixed? Due to forums which are lost the history of RandomTools is also lost. It is a collection of tools I compiled/gathered years ago, because I needed/wanted them on my NAS. Some of them I had shared as binaries, which often caused questions like where to store them, and how to execute, as the binary directories on a ZyXEL NAS are either volatile or read-only, and so I packaged them, as-is, without warranty. In that time I had just created MetaRepository, so packaging was possible.

    I know, the package is not perfect, and it's a strange collection of tools (hence the name). Yet it works for me and many others. The source of the terminfo package is lost in history. I can't remember. Maybe it's an OpenWrt package, maybe stripped from the ZyXEL SDK, maybe I compiled it. When I feel the need for a better terminfo, I'll fix it. Don't think that will happen soon, as the work-around is simple.

All Replies

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    But is this a known issue?  Should it be fixed? 

    It is a known issue, in the sense that I know xterm-256color is missing, as someone reported that before. So far it hasn't bitten me, maybe due to the ssh clients I use. The work-around is easy, as you found. You can also put a TERM=xterm in your profile, or something like that.

    Should it be fixed? Due to forums which are lost the history of RandomTools is also lost. It is a collection of tools I compiled/gathered years ago, because I needed/wanted them on my NAS. Some of them I had shared as binaries, which often caused questions like where to store them, and how to execute, as the binary directories on a ZyXEL NAS are either volatile or read-only, and so I packaged them, as-is, without warranty. In that time I had just created MetaRepository, so packaging was possible.

    I know, the package is not perfect, and it's a strange collection of tools (hence the name). Yet it works for me and many others. The source of the terminfo package is lost in history. I can't remember. Maybe it's an OpenWrt package, maybe stripped from the ZyXEL SDK, maybe I compiled it. When I feel the need for a better terminfo, I'll fix it. Don't think that will happen soon, as the work-around is simple.

  • Aylwin
    Aylwin Posts: 2  Freshman Member
    Options
    Thanks for the reply and thanks for the tools! In my opinion, they should all be included in the standard SW.  Regarding screen, you're right.  It's easy to get it working so no worries.

Consumer Product Help Center