NAS542 Unable to map UPnP port

Boyanski
Boyanski Posts: 33  Freshman Member
edited June 2020 in Personal Cloud Storage
Hello, I'm trying to enable HTTP on my NAS542, but it fails. Nothing happens, if I try to do it through MyZyxelCloud, it says "fail". Only WebDav is enabled, everything else is disabled and I cannot enable any of them.



I want to have access from outside the local network and I guess HTTP should be enabled.
I called my internet provider and asked if they block something, they said they don't put any limitations.
Any possible reasons?

#NAS_June_2020

All Replies

  • Sakura_T
    Sakura_T Posts: 101  Ally Member
    Check if your NAS's gateway and DNS IP been set correctly.

    Or instead of upnp, you may use port forwarding on your router for port 80
  • Penny
    Penny Posts: 65  Ally Member
     if I try to do it through MyZyxelCloud, it says "fail"
    Do you have a screenshot? 
    Maybe those ports are already occupied on your router?
  • Boyanski
    Boyanski Posts: 33  Freshman Member
    Here are my settings:




    The Gateway and DNS are my router's IP. I've set in the router DHCP server, so the NAS receives the same IP.



    The NAS has access to the internet, the ping is successful, firmware checking and updating works. Since I've set manual IP to the NAS, I also set NAT Forwarding in the router:



    So I enter the web interface with IP:8080
  • Sakura_T
    Sakura_T Posts: 101  Ally Member
    edited June 2020
    It seems to me that the internal port for HTTP should be 80?

  • Boyanski
    Boyanski Posts: 33  Freshman Member
    I tried with 80 and now everything is disabled and I can't enable any. Webdav is disabled and I thought ZyxelDrive won't work, but it works. From MyZyxelCloud I have hard time accessing the upnp settings.