ZyXEL home routers seems to be my worst enemies

Challa Posts: 1  Freshman Member

This is now my third different ZyXEL home router. I've had two with another ISP, which both just had random disconnects from the internet without it making any sort of sense as to what were causing it. I've had another ISP since though, which handed me a Technicolor router = No issues at all.

Now i have changed to a new one.. And from the start when they told me that i was going to get a ZyXEL router, i was afraid of it being the same usual unstable cr** equipment that i got the last time.. And for now, it seems that i was right..

I got my new ISP and router online on the 19th of August. I've been away from home since then, but i was home on the day, to set things up, including my VPN connection. However since that day i've had two disconnects where the router simply just drops all communication to its WAN side. When i got home to diagnose, nothing was out of the ordinary on the router, but it just did not want to connect to the outer world.. A reboot of the router fixed the problem in both occasions. What should i be looking for when this happens ? Is there anything i can do?

Also.. When i create port forwards on the router they usually do not work.. If i disable old port forward those continue to work, even though i have disabled them.. A reboot also fixes this, and why is that ?

The specific model i have is a VMG3925-B10B

Hope you have some tips for me. Since i have no trouble when not running ZyXEL routers i think it must be something i forget to configure on those bastards that i do not need to configure on other brands for some reason..


  • Hummel
    Hummel Posts: 212  Master Member
    First Anniversary Friend Collector First Comment
    edited July 2020
    What is the firmware version on your VMG3925-B10B?
    For the VPN connection, can you share more information for what the problem you meet? What is your topology? How do you setup to get the VPN connection? Do you mean it worked before but lost the connection suddenly and a reboot can solve the problem for a while?
    As for port forwarding function, according to your description, it worked but will suddenly stop to work. A reboot can resolve the problem. Right? If so, it means there should be no problem for the settings. But you might need to find out the clues which makes it to stop working. It will be useful if you can figure out the reproduce steps to show the problem.

Consumer Product Help Center