XMG3927-B50A 5GHz Wifi dropout

Options
JF0
JF0 Posts: 3  Freshman Member
Every few hours, the 5GHz network on my B50A drops out - the light on the router itself remains lit, but stops flashing, and nothing can connect to the 5Ghz WiFi. The 2.4Ghz channel is fine. This happens whether they share a SSID or not, and on auto channel or fixed. I see some other discussions on the same issue, but no resolution?
«1

All Replies

  • Hummel
    Hummel Posts: 212  Master Member
    First Anniversary Friend Collector First Comment
    Options
    Have you tried to fix the channel 36?
  • JF0
    JF0 Posts: 3  Freshman Member
    Options
    @Hummel - no, haven't tried that. What is the rationale for doing so?
  • tonygibbs16
    tonygibbs16 Posts: 860  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2020
    Options
    Hello @JF0 ,

    Do you know what firmware version your router is running?

    The release notes at ftp://ftp.zyxel.com/XMG3927-B50A/firmware/ say that there were a couple of bugs fixed in early 2019 that affected 5 GHz band performance and steering.

    Modifications in 5.13(ABMT.0)b4
    [FEATURE ENHACEMENT]
    1. [eits#181000036] customize DSL physical configuration
    2. [eits#180900667] Questionable RSSI - Different Values on PC/Router/MP App
    [BUG FIX]
    1. [eits#180900791] Band Steering back to 5G not working.
    2. [eits#181000022] 5GHz Performance issue 

    I hope that this is helpful.

    Merry Christmas and Happy New Year.

    Tony
  • JF0
    JF0 Posts: 3  Freshman Member
    Options
    Hi @tonygibbs16, I am on V5.13(ABMT.0)C0 which I believe is the latest version...
  • tonygibbs16
    tonygibbs16 Posts: 860  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2020
    Options
    Hello @JF0

    It is. I cannot suggest anything else on the firmware other than asking @Zyxel_Support_CPE directly.
        - and disabling 5GHz band if issue is annoying you.

    FYI, I range extended my Zyxel VMG1312-B10D (which has only 2.4GHz WiFi) with a TP-Link RE300 (which does 2.4GHz and 5GHz bands) and found it very useful and reliable. https://www.tp-link.com/uk/home-networking/range-extender/re300/

    Or consider looking at Zyxel's Multy X mesh products.

    Merry Christmas and Happy New Year.

    Tony
  • mYoda
    mYoda Posts: 4
    Friend Collector First Comment
    Options
    Hello everybody, @Zyxel_Support_CPE
    any news regarding this problem? I just bought a brand new Zyxel XMG3927-B50A and I'm facing the same issues...

    Any help would be appreciated,
    Thanks

  • mYoda
    mYoda Posts: 4
    Friend Collector First Comment
    edited October 2021
    Options
    @Zyxel_Support @Zyxel_Support_CPE @Zyxel_Stanley @Zyxel_Charlie @Zyxel_Emily @Zyxel_Cooldia @Zyxel_Jerry

    It's really disappointing to see that Zyxel actually doesn't care at all if their products are working or not.. the 5G is simply not stable! Any comment? Any fix to be expected?
  • SEJ
    SEJ Posts: 111  Ally Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hi,
    I found a post that there is a new firmware for XMG3927-B50A V5.17(ABMT.5)C0.
    https://community.zyxel.com/en/discussion/11497/xmg3927-b50a-firmware-version
    But if your router was provided by ISP, you may need to check with your ISP for newer firmware.

  • tonygibbs16
    tonygibbs16 Posts: 860  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Hello @mYoda and @SEJ

    Yes and it seems to be downloadable at https://www.zyxel.com/euosearch/dl-search.aspx?mci_country=uk&mci_lang=en&keyword=xmg3927&submit=Search as 5.17(ABMT.5)C0

    Kind regards,
        Tony
  • tonygibbs16
    tonygibbs16 Posts: 860  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited October 2021
    Options
    Hello @mYoda and @SEJ

    Looking at the release notes for the firmware, they say that there was a bug fix in 5.13(ABMT.2)b1 for 5 GHz beacon frames missing, see below extract.

    "Modifications in 5.13(ABMT.2)b1
    [BUG FIX]
    1. #94227 [e its 181200918] Missing 5ghz beacons"

    and for 5.15(ABMT.4)b5_D0 they say:
    "Modifications in 5.15(ABMT.4)b5_D0
    [BUG FIX]
    1. Sometimes 5G signal will disappear when Extender connects to wifi
    backhaul"

    So 5.17(ABMT.5)C0 might be helpful to you.

    Kind regards,
         Tony

Consumer Product Help Center