[Transmission-Daemon] Remove torrent after completed

kimme
kimme Posts: 35  Freshman Member
edited October 2019 in Personal Cloud Storage
Hi All!

As the title says:
Would it be possible to remove a torrent file after it's completed?

I checked that the settings.json is located at /i-data/4ebe74b4/.PKG/Transmission/config/Transmission.
However when I try to access it, the permission is denied and the file shows empty.
After trying "chmod u+rwx" it gives "Operation not permitted".

Any ideas?

Thanks in advance!

Kim


#NAS_Oct_2019

Comments

  • Mijzelf
    Mijzelf Posts: 1,785  Guru Member
    I think you'll have to stop transmission first, before editing the file.
  • kimme
    kimme Posts: 35  Freshman Member
    @Mijzelf I did via the GUI before attempting to edit it but it didn't work.
    I tried "service transmission-daemon stop" without succes as well via CL...

    Is there any other way that might work?
  • Mijzelf
    Mijzelf Posts: 1,785  Guru Member
    In a shell you can execute 'ps' to see all running processes, and look if transmission is running.

    How are you trying to edit the file? What is the output of
    ls -l /i-data/4ebe74b4/.PKG/Transmission/config/Transmission/




  • kimme
    kimme Posts: 35  Freshman Member
    edited October 2019
    Hi,

    thanks for the reply.

    using vi to edit.

    Requested output:

    -rw-rw-rw-    1 root     root             8 Oct 18 18:12 Transmission

    drwxrwxrwx    2 root     root          4096 Jan 21  2019 blocklists

    -rw-------    1 root     root           430 Oct 18 18:05 dht.dat

    drwxrwxrwx    2 root     root          4096 Oct 18 17:45 resume

    -rw-------    1 root     root          3734 Oct 18 18:12 settings.json

    -rw-------    1 root     root           162 Oct 18 17:46 stats.json

    drwxrwxrwx    2 root     root          4096 Oct 18 17:45 torrents

  • Mijzelf
    Mijzelf Posts: 1,785  Guru Member
    -rw-------    1 root     root          3734 Oct 18 18:12 settings.json
    Only root is authorized to edit that file. So you have to login as root.
  • kimme
    kimme Posts: 35  Freshman Member
    ah ok  thanks!
    in the meantime I was also able to solve the issue in another way but either way it's a great tip!