Configuring NAT on Zyxtel vmg8924 b10d (Tiscali provider)

Beorne
Beorne Posts: 5  Freshman Member
edited December 2019 in Smart Home Product
The router is perfect and has a very good interface.
I have added a set of NAT rules to my router configuration but i can't connect to these ports from outside. The adding of new NAT rule is very simple so I don't think to have messed up with the parameters, I have succesfully configured NAT ports on a number of previous routers with interfaces way worst than that of Zyxrtel.
What am I missing? Is there some global setting to enable / disable NAT port forwarding?

Thank you.

#SP_Dec_2019

Best Answers

  • Hummel
    Hummel Posts: 212  Master Member
    Accepted Answer
    @Beorne,
    Do you mind sharing your related settings with screenshoots and the test steps you used to verify the settings? According to your description, for me, it seems there should be no problem to use it with port forwarding rule to allow remote access to your local servers.
  • Hummel
    Hummel Posts: 212  Master Member
    edited December 2019 Accepted Answer
    @Beorne,
    Do you have only one WAN interface called VDSL_VoIP?
    Could you please also show the WAN interface configuration?
    About your test with Dominions server, do you mean you use your local PC to connect to the WAN IP which is 94.36.98.12 in your example? Have you tried to connect to your local server via the WAN IP from real outside PC?
    To be honest, I can't find anything wrong from your configuration.
    Have you tried to use DMZ feature (remember to clear all related port forwarding rules) since it looks you use the same PC for all port forwarding rules?

  • Beorne
    Beorne Posts: 5  Freshman Member
    Accepted Answer
    I have other WAN interfaces, like the following:


    --> I don't know where to find the Interface WAN configuration page, prthaps the problem is there but I haven't found it.

    I have tried to connect from ouside the local network with my friend PC and the result is the same, I can't connect.

    I have put the IP in DMZ, now all the incoming connections are ok, but the security of my PC is much lower I think. This is my functioning DMZ confiuration:


    I could keep it this way, but I think neverthless it should be better to open only specific ports.

    Thank you.

  • Hummel
    Hummel Posts: 212  Master Member
    edited December 2019 Accepted Answer
    @Beorne,
    It looks like you have many different WAN interfaces. It would be better if you can find out the name of the one you are using to access the Internet so that you can configure the port forwarding rules with correct WAN interfaces. Isn't there any web page shows you the WAN configuration?
    If you still can't figure out which one is correct, the worst case is to create rule for each WAN interface and see which one works. But according to your screenshot, I guess ETH should be the one you are using now because it shows Ethernet WAN is up on the status page and DSL is no link. It should not be VDSL_VoIP.

All Replies

  • NeAl
    NeAl Posts: 77  Ally Member
    edited December 2019
    Edit. Wrong model, sorry.
  • Hummel
    Hummel Posts: 212  Master Member
    edited December 2019
    @Beorne,
    What is the WAN IP protocol your VMG8924 is using now? Is it IPv4 or IPv6?
    Are you configuring port forwarding rule for your local servers so that you could access them from outside?
  • Beorne
    Beorne Posts: 5  Freshman Member
    My WAN IP is IPv4.
    Yes I am configuring them for access from outside, my public IP can be pinged so I can be reached, I have "opened" a single TCP protocol port on Wan Interface VDSL_VoIP (I think it is right for my fiber, but I have tried all the WAN Inteface options and the result is the same). I have checked the local lan of the server IP address is right, I have put it on into static DHCP it does not changes.
    Thanks.


  • Beorne
    Beorne Posts: 5  Freshman Member
    Yesm, no problem, you are very kind.
    This is the main router connection status window:


    This is my local network PC setup window, in wihch you se my PC local IP address:



    This is the NAT settings window. I have configured a game, Dominons, that uses a single TCP port, amd emule that uses a TCP and an UDP port:


    This is the Dominions local game server that hosts the game and awaits incoming connections:


    This is the Dominions client that I use to connect to the server. If I put as address 127.0.0.1:1024 to connect from the inside of local network it connects correctly, bit if I use the WAN IP address (as must do the other players)  it does not:




    This is emule network settings (sorry for the Italian!) where you can see the port configurations:


    Emule connects but the connection remains behind firewall with low ID because it can't open these ports ("dietro" means behind):


    Thank you very much,
    Happy Christmas!


  • Beorne
    Beorne Posts: 5  Freshman Member
    While trying with all the WAN Interfaces I have found that the default WAN interface is the right one. I have FTTH and probably VDSL_VoIP was not the right one.
    Thanks you all, this forum is full of very supportive people.