GS1920-24HP - WAX510D: Access points don't assing IP address in Corporative SSID

SC_Ivy
SC_Ivy Posts: 12
Friend Collector
edited April 1 in Nebula
Hello all.

Based on the following scheme: 



I'm experiencing a pretty weird behaviour when connecting to Access Points (Corporative SSID). Some computers are assigned with the correct IP address but other auto-assings an APIPA address (i.e. 169.254.89.135). The ports where the AP's are directly connected have the following configuration: 



Connection works randomly when VLAN is set to 10 (but there's no further switch configuration using this VLAN!!!).



If SSID is configured to use VLAN 1 (as default), an APIPA address is assigned.

Any idea if there's something wrong configured? Any help is apreciated, thanks in advance.

Kind regards.




Accepted Solution

  • Zyxel_Bella
    Zyxel_Bella Posts: 343
    25 Answers First Comment Friend Collector Second Anniversary
     Master Member
    Answer ✓

    Hi @SC_Ivy

     

    Thanks for the information. If you’d like to setup both APs broadcast two SSIDs, one is default management vlan and another is guest usage.

     

    Your AP model is WAX510D which supported NAT mode, we suggest you could configure first SSID with vlan id 1 and enable Guest Network and NAT mode on second SSID.

     

    However, there is a mis-configuration on WAX510D 2 as below, the IP of AP is set as DHCP vlan 10 that will cause clients connect to the SSID with vlan1 can’t get IP address. Please change the Management VLAN ID to 1 on WAX510D 2 to correct the settings then change the settings on SSID to accomplish your wireless network.


     

    Thank you

     

    Regards,

    Bella

     

     

     


All Replies

  • Zyxel_Bella
    Zyxel_Bella Posts: 343
    25 Answers First Comment Friend Collector Second Anniversary
     Master Member

    Hi @SC_Ivy

     

    According to your topology description, two scenarios as below presents different result.

    a.      wireless clients sometimes can’t get IP when SSID vlan id is 10.

    b.      all wireless clients can’t get IP when SSID vlan id is 1.

    On the second case, user doesn’t have to configure any settings because vlan id 1 is default management vlan, we suggest you could check if DHCP server assigns IP to clients or not since it could help to clarify the uplink path is fine.

     

    Please enable the Zyxel support at Help > Support request > Invite Zyxel support as administrator, save the changes for us to check your configurations.

    And provide the Org and Site name, thank you.

     

    Regards,

    Bella

     

     


  • SC_Ivy
    SC_Ivy Posts: 12
    Friend Collector
    edited March 25
    Hi @Zyxel_Bella.

    Both scenarios are perfectly described by you. I've checked DHCP configuration and seems to be correctly set up. DHCP server is the main Router, so the configuration is per default, as well as the uplink port.

    For the moment, I've configured wireless by using NAT mode (Zyxel DHCP & NAT) and it's working fine. But I'm a bit concern because I'm not able to manage IPs properly (using the same IP mask for whole Corporative wireless clients). Not a big deal while wireless clientes can reach the main subnet computers (192.168.1.x).

    Thanks for your support.
  • SC_Ivy
    SC_Ivy Posts: 12
    Friend Collector
    Hello @Zyxel_Bella.

    As well as you said, there was a mis-configuration on AP settings. Wireless config were set to point VLAN 10. Settings fixed to use VLAN 1 and all the devices are getting the correct IP (DHCP packets traffic flowing as expected...).  

    Apreciate for your support, thank you. Best regards

Nebula Tips & Tricks