NR7101unable to connect to web.vodafone.de

Hi there,
first of all: with my vodafone-cube I get a connection to a nearby antenna, even inside the building, the quality is not so good though.

With the NR7101 placed outside and directed towards the antenna, the connection remains down all the time, although the cells are listed in the scans. The APN-settings are the same as with the vodafone-cube.

I tried all different kind of things: original modem firmware R11A03 + router firmware 100ABUV3C0, automatic settings (manual APN setting though).

Then upgraded to R11A07 / 100ABUV5C0, still no connection. After each FW upgrade I did factory reset.

Now my latest test here in detail:
  • firmware R11A07 / 100ABUVC6b1_0221
  • manual APN web.vodafone.de
  • Restriction to 4G
  • 4G-PCI scan shows all available Cells!
  • Locking to the "target cell" does not help (tested with and without locking, even to several vodafone-cells which are shown in the PCI-scan)
Here comes the debug-logging:
Feb 21 00:00:23 user.notice RILCMD: set_LTE_connection_status: Down
Feb 21 00:00:23 user.notice RILCMD: zcfg_get_sim_slot() Preferred SIM Slot: 0
Feb 21 00:00:23 user.notice RILCMD: zcfg_get_sim_slot() Detach Switch: 0
Feb 21 00:00:24 user.notice RILCMD: SIM card ready after initialization
Feb 21 00:00:24 user.notice RILCMD: NR7101 with RG500Q/RG502Q module
Feb 21 00:00:26 user.notice RILCMD: GNSS function enable
Feb 21 00:00:27 user.notice RILCMD: User config RFCN&PCI to set cell lock/unlock
Feb 21 00:00:27 user.notice RILCMD: AT+QNWLOCK="common/4g",1,1801,378
Feb 21 00:00:31 user.notice RILCMD: User config RFCN&PCI to set cell lock/unlock
Feb 21 00:00:31 user.notice RILCMD: AT+QNWLOCK="common/5g",0
Feb 21 00:00:44 user.notice RILCMD: RILCMD_AUTO_APN flag enable.
Feb 21 00:00:44 user.notice RILCMD: PrevSetAccessTechnology:
Feb 21 00:00:55 user.notice RILCMD: RS_INIT::g_attach_status:0, item_ptr->attach_status:0
Feb 21 00:00:55 user.notice RILCMD: Change state from RS_INIT to RS_UPDATE.
Feb 21 00:00:55 user.notice RILCMD: RILCMD STATE: RS_INIT ============> RS_UPDATE
Feb 21 00:00:56 user.notice RILCMD: ************************* CM Connect *************************
Feb 21 00:00:56 user.notice RILCMD: *****working_cid:1****enable == [ 1] **
Feb 21 00:00:57 user.notice RILCMD: profile[1] = web.vodafone.de///0, pincode = (null)
Feb 21 00:00:57 user.notice RILCMD: PSAttachedState: 0
Feb 21 00:00:57 user.notice RILCMD: IPv4ConnectionStatus:1
Feb 21 00:00:57 user.notice RILCMD: IPv6ConnectionStatus:1
Feb 21 00:00:57 user.notice RILCMD: Close qmiclientId[0][1] 50
Feb 21 00:00:57 user.notice RILCMD: Close qmiclientId[0][2] 52
Feb 21 00:00:57 user.notice RILCMD: Close qmiclientId[0][3] 53
Feb 21 00:00:57 user.notice RILCMD: Close qmiclientId[0][11] 54
Feb 21 00:00:57 user.notice RILCMD: Close qmiclientId[0][17] 51
Feb 21 00:00:57 user.notice RILCMD: Close all the qmiclientIds of idx=0.
Feb 21 00:00:59 user.notice RILCMD: cid: 1 cgact_status[0]:0
Feb 21 00:01:00 user.notice RILCMD: RILCMD STATE: RS_UPDATE ============> RS_READY
Feb 21 00:01:01 user.notice RILCMD: quectel_rg500q_ready() Next to RS_ATTACH state
Feb 21 00:01:01 user.notice RILCMD: RILCMD STATE: RS_READY ============> RS_ATTACH
Feb 21 00:01:02 user.notice RILCMD: PrevSetAccessTechnology: LTE
Feb 21 00:01:03 user.notice RILCMD: RILCMD STATE: RS_ATTACH ============> RS_UPDATE
Feb 21 00:01:04 user.notice RILCMD: ************************* CM Connect *************************

-> This CM-Connect loops forever, the connection status stays "down" all the time.

What is going wrong here? Anyone else managed to connect to vodafone?

Thanks for any hints/ solutions!

Accepted Solution

  • rubbermaid
    rubbermaid Posts: 14
    Answer ✓
    Good news: the problem is solved!

    I was able to use another Vodafone SIM card, but one which was in use for a mobile phone. The connection was up shortly with APN web.vodafone.de

    So next I did was a little research for differences in Vodafone SIM cards, and it turned out that for the Gigacube-cards actually there is a different APN used: home.vodafone.de
    -> with this APN, the original SIM card worked with the NR7101.

    So it seems that in the Huawei and TLC-router the different APN is used (although in the router-settings there it says clearly web.vodafone.de!)

    Many thanks to Selberg for caring!

All Replies

  • rubbermaid
    rubbermaid Posts: 14
    I just tested what happens if APN is set to Automatic.

    The Debug-Log shows that all different APNs are tested (web.vodafone.de, wap.vodafone.de, event.vodafone.de, data.otelo.de, pinternet.interkom.de), notably PSAttachedState now shows up with "1" short time, but only for APN "wap.vodafone.de" (PSAttachedState was 0 all the time at APN-manual mode).

    Also with APN-automatic, the Cellular-Info page now shows valid Service information for a vodafone-cell. The Cellular-Status stays "Down" though, so there is still no connection.

    Debug-log:
    ...
    Feb 21 00:07:54 user.notice RILCMD: RILCMD STATE: RS_UPDATE ============> RS_READY
    Feb 21 00:07:58 user.notice RILCMD: ************************* CM Connect *************************
    Feb 21 00:07:58 user.notice RILCMD: *****working_cid:1****enable == [ 1] **
    Feb 21 00:08:00 user.notice RILCMD: profile[1] = wap.vodafone.de///0, pincode = (null)
    Feb 21 00:08:00 user.notice RILCMD: PSAttachedState: 1
    Feb 21 00:08:00 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:00 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:04 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:04 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:04 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:04 user.notice RILCMD: Close qmiclientId[0][1] 50
    Feb 21 00:08:04 user.notice RILCMD: Close qmiclientId[0][2] 52
    Feb 21 00:08:04 user.notice RILCMD: Close qmiclientId[0][3] 53
    Feb 21 00:08:04 user.notice RILCMD: Close qmiclientId[0][11] 54
    Feb 21 00:08:04 user.notice RILCMD: Close qmiclientId[0][17] 51
    Feb 21 00:08:04 user.notice RILCMD: Close all the qmiclientIds of idx=0.
    Feb 21 00:08:06 user.notice RILCMD: profile[1] = wap.vodafone.de///0, pincode = (null)
    Feb 21 00:08:07 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:07 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:07 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:11 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:11 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:11 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:11 user.notice RILCMD: Close qmiclientId[0][1] 50
    Feb 21 00:08:11 user.notice RILCMD: Close qmiclientId[0][2] 52
    Feb 21 00:08:11 user.notice RILCMD: Close qmiclientId[0][3] 53
    Feb 21 00:08:11 user.notice RILCMD: Close qmiclientId[0][11] 54
    Feb 21 00:08:11 user.notice RILCMD: Close qmiclientId[0][17] 51
    Feb 21 00:08:11 user.notice RILCMD: Close all the qmiclientIds of idx=0.
    Feb 21 00:08:13 user.notice RILCMD: profile[1] = web.vodafone.de///0, pincode = (null)
    Feb 21 00:08:14 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:14 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:14 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:18 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:18 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:18 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:18 user.notice RILCMD: Close qmiclientId[0][1] 50
    Feb 21 00:08:18 user.notice RILCMD: Close qmiclientId[0][2] 52
    Feb 21 00:08:18 user.notice RILCMD: Close qmiclientId[0][3] 53
    Feb 21 00:08:18 user.notice RILCMD: Close qmiclientId[0][11] 54
    Feb 21 00:08:18 user.notice RILCMD: Close qmiclientId[0][17] 51
    Feb 21 00:08:18 user.notice RILCMD: Close all the qmiclientIds of idx=0.
    Feb 21 00:08:20 user.notice RILCMD: profile[1] = web.vodafone.de///0, pincode = (null)
    Feb 21 00:08:20 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:21 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:21 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:25 user.notice RILCMD: PSAttachedState: 0
    Feb 21 00:08:25 user.notice RILCMD: IPv4ConnectionStatus:1
    Feb 21 00:08:25 user.notice RILCMD: IPv6ConnectionStatus:1
    Feb 21 00:08:25 user.notice RILCMD: Close qmiclientId[0][1] 50
    Feb 21 00:08:25 user.notice RILCMD: Close qmiclientId[0][2] 52
    Feb 21 00:08:25 user.notice RILCMD: Close qmiclientId[0][3] 53
    Feb 21 00:08:25 user.notice RILCMD: Close qmiclientId[0][11] 54
    Feb 21 00:08:25 user.notice RILCMD: Close qmiclientId[0][17] 51
    Feb 21 00:08:25 user.notice RILCMD: Close all the qmiclientIds of idx=0.
    ...


    Anyone having a clue what is going wrong?


  • SELBERG
    SELBERG Posts: 78  Ally Member
    edited June 10
    Network setting - Broadband -Cellular APN...

    Modify...

    Unthick IP-passthrough and finally OK!

    😀

  • rubbermaid
    rubbermaid Posts: 14
    Although I tried that before, I did a factory reset, then disabled "IP Passthrough" and enabled the logging. But everything happened as mentioned above:
    • the connection stays down,
    • only for APN wap.vodafone.de the debug-loggin temporarily had PSAttachedState: 1,
    • Cellular-Info page shows valid Service information for a vodafone-cell
    When I set APN mode to manual with web.vodafone.de:
    • the connection stays down,
    • whenever there is PSAttachedState in the debug-logging, it is 0
    • Cellular-Info page shows N/A all over

    What to test next? Some zyxel-officials that can help me out here?

    I have an expensive piece of hardware not working...

  • SELBERG
    SELBERG Posts: 78  Ally Member
    edited June 11
    All settings to Auto even sim and APN, be sure IP-passthrough  is unthicked. Then turn off the power for a few minutes and try again.


  • rubbermaid
    rubbermaid Posts: 14
    Hi Selberg,
    thank you for pointing that out again.

    I already had those settings as suggested, so now I made sure to have the device powered off for 5 minutes. Then, after switching power on again, I let it run for 20 minutes, but everything was as before:
    • the connection stays down,
    • only for APN wap.vodafone.de the debug-loggin temporarily had PSAttachedState: 1,
    • Cellular-Info page shows valid Service information for a vodafone-cell,
    • after some minutes, the Service information shows N/A again,
    • after a while it repeats (shows valid vodafone-cell etc.).
    Selberg, it seems you are confident that it should work with those settings. Do you have the NR7101 working within the German vodafone mobile net?

    @zyxel: what about 100ABUV6b2, could you provide a download of that to me for testing? Or when is the release of 100ABUV6C0 planned?

  • rubbermaid
    rubbermaid Posts: 14
    Feedback after more than 10 days: contacted local zyxel support, who went through testing the same things I already did, then escalated, now again testing of settings -> still no success.
    -> sadly, this does not seem to go anywhere... is anyone aware of new firmware-update 100ABUV6C0?

  • SELBERG
    SELBERG Posts: 78  Ally Member
    edited June 23
    Sent you a message!

Consumer Product Help Center