NWA50AXs crashing if I have two SSIDs where one only uses the 2.4GHz band

letalvoj Posts: 2
First Comment
edited October 2022 in WirelessLAN
I am in a very specific situation. I have a Xiaomi Mop P, which only supports 2.4GHz WiFi, which I did not know.

I got a pair of NWA50AX, connected them to a router via ethernet cables, enabled Smart Mesh ... and realised I can not control the robot anymore.

Later I got an idea. Let's create a second SSID which will only use the 2.4GHz band. It seemed to be working fine at first but then it started. Both APs started disconnecting from the router (crashing?). All I saw most of the time was a green-orange blinking of the indicator LED. After a while it started working again until the robot tried to connect to the WiFi. That caused the, to disconnect from the router again.

The issue was solved by removing the extra 2.4GHz only SSID.

Is it a bad idea to have one SSID which only uses one of the bands? Should it work in the first place? Or is this behaviour just a bug?

All Replies

  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 138
    5 Answers First Comment Friend Collector
     Ally Member

    Most of Iot devices only support using 2.4G Wi-Fi to connect, we always suggest users to set up a 2.4G only SSID for their IoT devices as what you done.

    Since we received similar issues after devices upgrading to the latest version 6.29P0, we’re looking into your symptom cautiously and still checking.
    To avoid firmware impact, we have applied the date firmware for you to observe if there still having issue in your scenario.

    Please help us to activate support access by following the steps in the link below:
    Thank you.
  • letalvoj
    letalvoj Posts: 2
    First Comment
    edited October 2022
    Hi. I have reset the hard devices, removed the 2nd SSID. Hence the access is not gonna give you much, not even the logs.

    On the other hand, I stumbled upon a hint on Reddit. Disable the 5GHz band just for device pairing and reenable it back later. And surprisingly it worked.

    What I did was to create a B/G hotspot with the same SSID and PWD, connect the vacuum to it, disabling hotspot, enabling my AX WiFi again and voila! Vacuum connected successfully!

    Mentioning it here because it might help someone. Yet, if you manage to fix the issue with crashing I will definitely create a separate SSID such that I do not have to deal with this in the future.