How to transfer data

Options
kcbass1
kcbass1 Posts: 9  Freshman Member
First Anniversary First Comment
Hi All,  I have a NAS326 with two 4TB hard drives as Raid 0.  I want to transfer my files to two 8TB in a Raid 1 configuration.  I formatted the 8TB as EXT4 and copied over a few files as a test.  Soon as the put the 8TB in the NAS326 it reads that the 8TB aren't formatted and will not do anything until I again format the 8TB.  But of course then all the data is gone.  How do I transfer my data to the 8TB's without losing it?  Thanks in advance.  Casey

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Oh right. The problem is that an internal disk is only accepted when it has a special formatting, but that formatting is not recognized on an external disk.
    And there might be another problem either. Some USB-Sata convertors do a sector size translation, rendering the partition table unusable when connected directly on Sata. Sigh.

    Assuming there is no problem with your USB-Sata convertor you should format the disk internally. Then connect it externally, and open an ssh shell (as root) to assemble&mount the disk manually.
    Find the device name of the disk:

    cat /proc/partitions

    You are searching for a device containing around 8 000 000 000 blocks of 1 kB each. Let's assume it's sdc.

    assemble the raid array:

    mdadm --assemble /dev/md4 /dev/sdc3 --run

    When the disk was not sdc, you'll have to change that in the command. Now it becomes tricky. Sometimes the firmware will dive in and mount the newly assembled array, sometimes it doesn't. Don't know what triggers it. So look in the webinterface if a new volume appeared.
    If not, mount it:

    mkdir /mnt/mountpoint
    mount /dev/md4 /mnt/mountpoint

    Again, have a look in the webinterface. If the volume doesn't show up, you'll have to do the copying manually too:

    cd /mnt/mountpoint
    df .
    cp -a /i-data/sysvol/* .

    Notice the dots on the ends.If 'df .' doesn't show terabytes of free space, don't start copying. Something went wrong, and you're on a ramdisk now. 

All Replies

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    How was the 8TB disk connected during file transfer? An external Linux PC, or USB?
  • kcbass1
    kcbass1 Posts: 9  Freshman Member
    First Anniversary First Comment
    Options
    It was usb directly to the NAS..  I formatted it first internally.  But when I hook it up to usb it reads not formatted. So i format it again via usb. Go through the copy procedure, the lights start flashing.  When the lights stop, I check the usb drive and nothing is there!
  • kcbass1
    kcbass1 Posts: 9  Freshman Member
    First Anniversary First Comment
    Options
    P.S. The format is EXT4.
  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Oh right. The problem is that an internal disk is only accepted when it has a special formatting, but that formatting is not recognized on an external disk.
    And there might be another problem either. Some USB-Sata convertors do a sector size translation, rendering the partition table unusable when connected directly on Sata. Sigh.

    Assuming there is no problem with your USB-Sata convertor you should format the disk internally. Then connect it externally, and open an ssh shell (as root) to assemble&mount the disk manually.
    Find the device name of the disk:

    cat /proc/partitions

    You are searching for a device containing around 8 000 000 000 blocks of 1 kB each. Let's assume it's sdc.

    assemble the raid array:

    mdadm --assemble /dev/md4 /dev/sdc3 --run

    When the disk was not sdc, you'll have to change that in the command. Now it becomes tricky. Sometimes the firmware will dive in and mount the newly assembled array, sometimes it doesn't. Don't know what triggers it. So look in the webinterface if a new volume appeared.
    If not, mount it:

    mkdir /mnt/mountpoint
    mount /dev/md4 /mnt/mountpoint

    Again, have a look in the webinterface. If the volume doesn't show up, you'll have to do the copying manually too:

    cd /mnt/mountpoint
    df .
    cp -a /i-data/sysvol/* .

    Notice the dots on the ends.If 'df .' doesn't show terabytes of free space, don't start copying. Something went wrong, and you're on a ramdisk now. 

Consumer Product Help Center