NSA325 v2 - No LAN port response

Dear,

I was suddenly not able to reach the web page of my NSA325 v2, SMB was still working and my TV was able to play my media files from the NAS.

I rebooted the NAS which seems to properly react on the front button but now it seems the LAN port is not doing anything anymore :'( . The LEDs are blinking but Wireshark shows no packets at all coming from the LAN port.

So 2 questions:
  1. Any chance I can diagnose or get this port up and running again?
  2. Can I buy a new NAS326 e.g. and recover my media from the 2 HDDs from my current NAS (Raid 1)? I.e. insert the 2 HDDs in the new NAS en get it up and running?
Thank you in advance!

All Replies

  • Mijzelf
    Mijzelf Posts: 2,002  Guru Member
    It must be coincidence, that http failed first. At ethernet level there is no difference between http and samba.

    2) The 326 won't accept the disks as they are. But the disks use normal Linux software raid and filesystem, so you can assemble and mount the disks manually in that 326, using an ssh shell. (As you can do in any Linux system with sata ports). So you could create a single disk volume, plugin one old disk and assemble it degraded, copy data over and finally add a 2nd disk to the volume to get redundancy.
  • Hi Mijzelf, thank you for your answer.

    I just figured I had an old one-bay NSA310 laying around which I tried and is now running with one disk of the NSA325. It seems I can just access my files via that old NAS which will make it easy to just copy them over to the new 326.

    The 325 is acting weird, a long reset on the reset button makes it wake-up again and I can assign a new IP address from where it works normal for a couple of hours until http starts to fail, then later on samba and eventually ftp. Curiously, ICMP never stops during that process, I've got continuously ping replies.
  • Mijzelf
    Mijzelf Posts: 2,002  Guru Member
    Do you have shell access? I wonder if you see a lot of errors in ifconfig. I have seen that before, on a Linux box, that after some time it was no longer possible to create new TCP connections from outside. A kernel issue, restarting the daemons didn't solve the problem. ICMP kept working, cannot remember UDP. I think the TCP stack was poisoned by too much noise in the data.

    Have you tried another cable, and/or switch port?
  • Mijzelf said:

    Have you tried another cable, and/or switch port?

    I removed it and hooked it up directly to my laptop already but it's the same.
    ~ # ifconfig egiga0
    egiga0    Link encap:Ethernet  HWaddr E8:37:7A:
              inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:58782338 errors:0 dropped:0 overruns:0 frame:0
              TX packets:310559145 errors:0 dropped:1197 overruns:0 carrier:0
              collisions:0 txqueuelen:532
              RX bytes:3534753850 (3.2 GiB)  TX bytes:1922355407 (1.7 GiB)
              Interrupt:11
    This looks ok to me, it doesn't increase but of course it's taken when the NSA "works" I should monitor if it acts up again.

Consumer Product Help Center