LTE5366-M608 unstable GSM/LTE connection + SSH login trouble

Kriz
Kriz Posts: 2
edited November 2021 in Mobile Broadband
Hello,

I recently got an LTE5366-M608 router and use the LTE only, with 2nd WAN disconnected. It mostly works fine, but at times the internet connection fails, with ping (8.8.8.8) showing either "Reply from 192.168.1.34: Destination host unreachable." or "Request timed out." This issue resolves sometimes spontaneously in about a minute, but sometimes I have to power-cycle the router and it helps. 

Now, I upgraded the firmware to V1.00(ABKA.0)C0 and for a few days I thought the problem was gone, it's still there though.
I tried logging ping results with a script and only once, after the upgrade, the output said "Reply from 100.87.xxx.xxx: Destination host unreachable." (like the default gateway displayed in admin panel; meaning it's an ISP problem, am I right?)

I tried some troubleshooting to see if the problem lies in the router or at my ISP's side or is due to heavy traffic on the BTS near me, but I can't SSH into it using Putty to (for instance) ping the ISP IP while the problem occurs.

Tbh I can't SSH into it at all, although I enabled SSH. Right now I connect my laptop to the router with an Ethernet cable as I didn't fancy loging into it with plaintext via my WiFi, and other devices use the WiFi. I also reserved one IP address for my laptop just in case. I can't get to the password prompt in Putty - I get the "no supported authentication methods available (server sent publickey)" after entering the username. Actually I tried to connect while writing this post and my Putty scared me out saying the server's host key does not match the one PuTTY has cached in the registry... should I worry?

I can at all times normally login via the admin panel, but I'm not sure what's wrong with the network scan tool, as the buttons disappear in a blink after every reloading of the toolbar. I use Chrome and Firefox, and in incognito mode it's the same. I have JS disabled by default on all sites and turn it on manually, I turned it on in this case though.

I also made a pair of RSA keys in Putty Key Generator, can't put the public one on the router though.

So, if I may ask:
1. How should I proceed with diagnosing/troubleshooting the internet connection problems?
2. What should I do to be able to SSH into the router? If it's not really needed for 1st question, I'd still like to be able to do it - though in a different topic maybe :).
3. Is there a way to put the RSA key on the router without SSH access? Could it make logging in via Putty work?
3. Is it something trivial I overlooked that I can't use the network scan in the admin panel? 

Thank you for your time :).


All Replies

  • tonygibbs16
    tonygibbs16 Posts: 365  Master Member
    edited November 2021
    Hello @Kriz

    Can you login to your LTE5366-M608 at all?

    If yes, then you need to set-up SSH under the Remote Management screen of the device.
       - section 20.5 of the user guide at https://download.zyxel.com/LTE5366-M608/user_guide/LTE5366-M608_V1.00.pdf from https://www.zyxel.com/uk/en/products_services/4G-LTE-A-Indoor-IAD-LTE5366-M608/downloads explains the settings.

    for your point 1, section 25.4 of the user guide has some troubleshooting tips.

    Kind regards,
          Tony
  • Kriz
    Kriz Posts: 2
    edited November 2021
    Thanks for your answer @tonygibbs16 

    Yes, I can login normally via the http interface.

    I dived into the docs. In the section 25.4 I followed the "Internet connection is slow or intermittent" part. No heavy traffic in my LAN, the signal strength is at 3 bars out of 4. It is possible that there are numerous networks connecting nearby, as a handful of directional antennas are visible on the rooftops of nearby blocks of flats - and all are facing the same Internet provider antenna as I do. But then again I noticed, that apart from the short 1-minute long episodes there are sometimes longer connection issues around 8-9 a.m. and then later around 1-3 p.m. when my ISP's IP is unreachable (ping).
    The traffic in my neighborhood could explain it, but would it be behind all the episodes when I can't ping anything past 192.168.1.1?

    Considering the SSH I would be really grateful for a little help with the contents of sections 20.4 and 20.5.
    I have the HTTPS set at the default port 443 for all IPs in LAN and HTTP set at port 89 for all IPs in LAN in the WWW tab. In the Remote Management tab I have the Remote Management enabled for 192.168.1.33/24:89 (.33 now reserved for my PC) and the SSH Management enabled for the same IP on port 20025.
    Pasting that into Putty ends with getting an unknown RSA key fingerprint, and if continued I'm allowed to type in the username. Straight after hitting Enter "No supported authentication methods available (server sent: publickey)" error pops up.
    In the logs there are these 2 new lines afterwards: 
        dropbear[14554]: Child connection from 192.168.1.33:51824
        dropbear[14554]: Exit before auth: Exited normally
    or similar on ports oscillating around 51xxx.

    Sorry about having so many questions and thnaks for reading all that, any answers are welcome!

    A. Can I somehow improve stability? Otherwise considering section 25.4, the QoS is enabled.
    B. I wonder also, could the RSA keys be generated anew after each reboot/reset, unless a custom one is set? I hope it should fix my SSH issues?
    C. Would you recommend some software to check up on what's exactly happening between Putty and my router?

Consumer Product Help Center