Can no longer connect via SMB (Port 445) to NSA325-v2

Options
Hi, for some reason I can no longer connect via SMB (Port 445) to my NAS (NSA325-v2) --> same issue with several windows 10 laptops.
I've updated the NAS to Samba 3.6.25 to support SMB2. To be on the safe side I've also activated SMB1.0 for the windows 10 laptops (control panel, turn on windows features, SMB1.0)
When mapping a network drive to a NAS share (in the same way I did it in the past) I get the following error:
'The remote device or resource won't accept the connection.'
The detailed error message says: 'The device or resource (192.168.0.3) is not set up to accept connections on port "The File and printer sharing (SMB)".
I can the NAS with its IP address via http (web interface) and ftp --> successful connection.
I also tried to connect via telnet to 192.168.0.3 445 --> same error, no connection.
Do you have an idea what the issue could be?

All Replies

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Long shot: you installed the 'zyxel-samba-replacement' package. There is some known bug, the installer is supposed to create an /opt/var/run symlink to /tmp (or /run, does that exist?), and for some reason that sometimes fails, in which case smbd doesn't start. Have a look at it.


  • martimus
    Options
    Hi, thank you for the quick replay and the hint. I've uninstalled the 'zyxel-samba-replacement' package and now it works again :)


Consumer Product Help Center