Sim Card Not Ready

I just bought a LTE3302-M432 and now try to make it work, to no avail : despite the SIM card working in a phone, I got the message "SIM card not ready" on the web interface of the router, and blinking red on LTE signal LED. I checked online and looks like that's quite a classic issue, that's being resolved by Zyxel Support team through direct communication. Anybody there to help ? I would really appreciate any advice.
This is the screen shot of the Modem Status 

All Replies

  • Miaa
    Miaa Posts: 25  Freshman Member
    Hi Pawel , the modem information all shows N/A is oddly. Did the problem happen at the first time bootup the device? Is it possible exchange a new one from the store where you bought the device?
  • Pawel
    Pawel Posts: 2
    Hi Miaa,
    it was working for a while without any issues, then because of the Covid Pandemic, everyone moved to working from home , so the router was not in use. Recently I switched it on again, and it did not connected. Sim card works fine when inserted to the phone , and tried few different operators with no luck. It cannot be exchanged unfortunately. Could you suggest anything else? Could it be down to wrong set up or firmware - I have tried to update it but it shows that the file I am uploading is incorrect, however it comes from Zyxel website??

Consumer Product Help Center