How to enable remote access for NAS326

Hello. I have 2 questions

1. Will a factory reset keep my data intact?

2. How do I set up my NAS326 for remote access over the internet? I want to access my files remotely from a windows pc. I have paired with myzyxel and created a zyxel.me name but nothing works. I have been tinkering for hours, please walk me through this step by step. I am completely unable to make this work and the manual does not help.

Thanks in advance.

All Replies

  • ikubuf
    ikubuf Posts: 30  Freshman Member
    edited March 24
    Reset the nas will not delete your data.
    But the IP address will reset, and also the account will unregister.
    You will need to register account again after reset the nas.
    as the ddns, are you using public or private? if you're using public, that would be no problem with it.
    But it is not secure, I'll suggest you not use public ip on the NAS.
    If you are using private IP, you should set ddns on the top of gateway and do port forwarding/NAT to the NAS you have.
  • NAShaver
    NAShaver Posts: 4
    Hello ikubuf.
    Thank you very much for your answer.
    I am factory resetting the NAS now.
    I was just using *.zyxel.me - will this work or do i need some other service... i also tried noip... 
    Can you expand upon your last sentence - how do i create a private ip and set ddns on top of the gateway... how do I enable accessing the NAS remotely from within the zyxel software... Should I enable HTTPS, CIFS, media server or something else entirely?
  • ikubuf
    ikubuf Posts: 30  Freshman Member
    edited March 25
    Do you have a router/firewall above your NAS?
    Normally, if you have a router or firewall above your NAS, your NAS is using private ip.
    If you need a ddns to access the NAS, you need to setup ddns on the router/firewall.
    I do not have router, here is my firewall settings for example.
    1. Check what's public ip is your router using
    2.Sign in no.ip and set up a hostname for the ddns

    3. Setup ddns on the router/firewall

    4. Setup NAT/ port forwarding on the router/firewall



    Then you can use ddns to access the NAS

  • NAShaver
    NAShaver Posts: 4
    Thank you very much for your answer... I feel like it's close to working...
    I have set up no-ip with the routers public ip and enable ddns from no-ip within the router.
    I have made a virtual server / port forwarding-rule enabling TCP traffic to port 80 / 80, specifying the routers internal ip adress as the target.

    However, I am still getting "SERVERNAME.ddns.net refused to connect," when I am trying to access through Edge.

    HTTP traffic at port 80 is enabled in network configuration. Is there anything else in the router settings or zyxelcloud that needs to be enabled? Should the internal / external ports be different in the port forwarding rule?
  • NAShaver
    NAShaver Posts: 4
    When going to SERVERNAME.ddns.net, I am presented with my routers login screen.
    I tried changing the port number to 8000 in the zyxel web configurator and in the router's port forwarding (internal and external port), and going to SERVERNAME.ddns.net:8000 - now the browser reroutes to http://SERVERNAME.ddns.net:8000/r51209,/desktop,/login.html and then times out.
  • Mijzelf
    Mijzelf Posts: 1,982  Guru Member
    Does accessing the nas on port 8000 within your lan still work?
  • ikubuf
    ikubuf Posts: 30  Freshman Member
    You can set up a different port on wan, not using 80. ex: 55535,
    when access  SERVERNAME.ddns.net:55535 it should do port forwarding to the NAS

    As Mijzelf said, you can double confirm if the NAT port forwarding work within your lan to check it.

Consumer Product Help Center