Nas 540 broken after power-outage

Options
2»

All Replies

  • Fever
    Fever Posts: 7
    First Comment
    edited October 2022
    Options
    Mijzelf said:
    I pm'd you a link to a compatible ddrescue. About the re-creation of the array, I suppose you mean re-assembling? Your headers show a creation time in 2016, which would be changed when you re-created them.
    As you can see sdb3 shows an array state of AAA., while both sda3 and sdc3 show an A.A. . So sda and sdc tell sdb was dropped. Sdb doesn't 'know' about that, because he wasn't updated after being dropped. Mdadm won't put sdb back in the array, because sda and sdc disagree.
    Maybe there is a way to force sdb back in the existing array, but I'm not aware of that. The only way I know is to create a new array around the existing payload.
    Having said that, sdb3 is updated last night, so it looks like it *was* back in the array at Fri Oct 21 00:17:57 2022, and was dropped again at Fri Oct 21 00:18:39 2022.
    How did you manage to do so?
    Anyway, when it was dropped within a minute, that disk has serious problems, and so it's not a good candidate for a healthy array. A copy is needed.


    Thank you for the link :-)

    I wish I knew why sdb was updatet yesterday. I tried to start the NAS with one new disk as sdd and was hopping that it could recover on its own. But I did not tell the system to do anything (yet) besides power on and power off.

    It seems like drive 4 (ata4) is working (somehow) but it makes no sense at that rate....

    ~ # ddrescue /dev/sdb /dev/sda /tmp/mapfile --force
    GNU ddrescue 1.26
    Press Ctrl-C to interrupt
         ipos:   72482 kB, non-trimmed:    61440 B,  current rate:   21845 B/s
         opos:   72482 kB, non-scraped:        0 B,  average rate:   25031 B/s
    non-tried:    6001 GB,  bad-sector:        0 B,    error rate:       0 B/s
      rescued:   12390 kB,   bad areas:        0,        run time:      8m 15s
    pct rescued:    0.00%, read errors:        1,  remaining time:   3206d  7h
                                  time since last successful read:          0s
    Copying non-tried blocks... Pass 1 (forwards)
  • Mijzelf
    Mijzelf Posts: 2,682  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options
    Well, so far it has copied 73MB, without detecting some sectors could not be copied. When you are lucky, the problem is mainly on the start of the disk. If not, it will takes 10 years before you know if the result is usable at all.

Consumer Product Help Center