NSA325v2 - Rescue Data from single HDD -

Hello everybody,

my name is Bastian and I had a NSA325v2 with a single disk (3TB Seagate) running as a personal storage. Mainly because I am using multiple Macs/Laptops etc.

So far so good.

As of today, I am not able to access my files because the NAS starts rebooting once the HDD is installed. It keeps active once disconnected the HDD...

I got myself a HDD Dock and want to safe/rescue my data on the HDD.

I tried several methods described on the internet but no luck whatsoever...

Last thing I tried was this:

[email protected]:/home/ubuntu# lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
loop0    7:0    0   2,3G  1 loop /rofs
loop1    7:1    0     4K  1 loop /snap/bare/5
loop2    7:2    0  61,9M  1 loop /snap/core20/1405
loop3    7:3    0 248,8M  1 loop /snap/gnome-3-38-2004/99
loop4    7:4    0 155,6M  1 loop /snap/firefox/1232
loop5    7:5    0   284K  1 loop /snap/snapd-desktop-integration/10
loop6    7:6    0  81,3M  1 loop /snap/gtk-common-themes/1534
loop7    7:7    0  43,6M  1 loop /snap/snapd/15177
loop8    7:8    0  45,9M  1 loop /snap/snap-store/575
sda      8:0    0 931,5G  0 disk
├─sda1   8:1    0   200M  0 part
├─sda2   8:2    0 930,7G  0 part /media/ubuntu/System
└─sda3   8:3    0 619,9M  0 part
sdb      8:16   1     0B  0 disk
sdc      8:32   1  29,7G  0 disk
├─sdc1   8:33   1   3,4G  0 part /cdrom
├─sdc2   8:34   1   4,1M  0 part
├─sdc3   8:35   1   300K  0 part
└─sdc4   8:36   1  26,3G  0 part /var/crash
                                 /var/log
sdd      8:48   0   2,7T  0 disk
├─sdd1   8:49   0   487M  0 part
└─sdd2   8:50   0   2,7T  0 part
sr0     11:0    1  1024M  0 rom  


[email protected]:/home/ubuntu# sudo smartctl -i /dev/sdd2
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.15.0-25-generic] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               
Product:              IB-1232CL-U3
Revision:             0
Compliance:           SPC-4
Logical Unit id:      0x5000000000000001
Serial number:        00000000000000000000
Device type:          disk
Local Time is:        Fri May  6 08:50:13 2022 UTC
NO MEDIUM present in device
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

I tried to mount the device but no luck.

I also tried to use another superblock because I get error messages but no luck at all...

[email protected]:/home/ubuntu# mke2fs /dev/sdd2
mke2fs 1.46.5 (30-Dec-2021)
Warnung: Sektor 2 konnte nicht gelöscht werden: Eingabe-/Ausgabefehler
Ein Dateisystem mit 732441600 (4k) Blöcken und 183115776 Inodes wird erzeugt.
UUID des Dateisystems: 2c8068a7-b16c-4066-ad89-3059f3a01cf6
Superblock-Sicherungskopien gespeichert in den Blöcken:
    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
    4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
    102400000, 214990848, 512000000, 550731776, 644972544

beim Anfordern von Speicher für die Gruppentabellen: erledigt                            
Warnung: Block Eingabe-/Ausgabefehler konnte nicht gelesen werden
Warnung: Sektor 0 konnte nicht gelöscht werden: Eingabe-/Ausgabefehler



Is there something I am missing or terribly wrong about?

Or is the HDD "just" gone?

I appreciate any type of help!

All Replies

  • Mijzelf
    Mijzelf Posts: 2,140
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    A few pointers: On a ZyXEL NAS the data filesystem is always in a RAID container, even if it's a single disk volume. So you should first assemble that array:
    mdadm --assemble /dev/md0 /dev/sdd2 --run
    After assembling you can mount /dev/md0
    Seeing the output of mke2fs I conclude the disk is in a bad shape. Not totally dead, (the partition table is readable, and mke2fs seems to have succeeded in writing some superblocks, but it also spawns some I/O errors).
    Your mke2fs action is potentially deadly for your data, as it puts a new, empty filesystem on your precious data. But because the partition starts with a raid header, the result might be less destructive. You can at least try to assemble the array and mount it, to get your data back.

    The smartctl action was on the wrong device. You should run it on /dev/sdd, not /dev/sdd2.

    Have you tried if the NAS boots with another disk? It might be a power supply problem.

  • Bastian_D
    Bastian_D Posts: 3
    Thank you for your quick answer.

    This is exactly what I’ve been trying to do in the first place but I always get the following message:
    mdadm: /dev/sdd2 has no superblock - assembly aborted

    And this led me to the mke2fs action trying to recover the superblock from backups…

    no luck

    Is there a different approach to restore the super block or write a new one (don’t know if this is even possible) with standard zyxel values?
  • Mijzelf
    Mijzelf Posts: 2,140
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    Ah right. From your first post I didn't understand you already tried to assemble the array. So something is wrong with the start of sdd2. It should contain a raid header, but apparently it doesn't. And mke2fs was not able to write the first sectors of it.
    Normally it's possible to write a new raid header, but as mke2fs couldn't write the sectors I assume mdadm can't either.
    But a raid member is nothing more than a partition with a header, so the 'real' data just starts with an offset. The default data offset on a raid1 in a NSA325 is 2048 sectors, which is 1048576 bytes.
    So execute
    losetup --find --offset 1048576 /dev/sdd2
    When nothing changed it will create a loopdevice loop9 (0 to 8 are already used, according to your lsblk) which contains your filesystem.
    mkdir /mnt/mountpoint
    mount /dev/loop9 /mnt/mountpoint

  • Bastian_D
    Bastian_D Posts: 3
    Tried your last answer… no luck

    op to loop9 everything works but I can’t mount it. Same error message. No superblock 

    think it went south and I might made it worse with my efforts.

    I also tried testdisk and it gives me some sort of answers but can’t find superblocks as well..

Consumer Product Help Center