NAS326 web gui stuck in NFS package update loop after fw update to 5.21

24

All Replies

  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    installed.list now reads:

    MetaRepository 0-013-0 Installed/MetaRepository_20160513_arm_013.zpkg
    RandomTools 0-010-0 Installed/RandomTools_20160117_arm_010.zpkg
    ffp 0-005-0 Installed/ffp_0.7_arm_005.zpkg
    myZyXELcloud-Agent 0-0105-0 Installed/myZyXELcloud-Agent_1.0.5_arm_0105_326.zpkg


    fw is 5.21

  • Mijzelf
    Mijzelf Posts: 2,139
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    is there a log from the webui to see where it's hanging please?
    The webui runs in the browser. So the logging should be in the browser. *Maybe* the browser console shows a clear error. (Ctrl+Shift+C in Firefox). But knowing ZyXEL there will be a lot of errors/warnings anyway.
    when i factory reset i'll lose the FFP, just busybox?
    The reset doesn't remove the packages, it just disables them. You can re-enable them in the package manager. (If the webinterface runs again)
    will telnet or ssh be ON by default?

    Good question. The firmware telnet and ssh are disabled. So if the webinterface doesn't come up, you have locked yourself out.

    A workaround could be an ffp stick, or the 'general purpose stick', which can startup telnet on boot.

  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    edited August 24
    ok so here's what firefox console shows, does this mean anything to you please? "temp is undefined".

    i will look into making an ffp stick and be sure i have that working before a reset. i will first try removing the other packages as you suggested (except ffp, becaiuse i really dont want to break ssh).

    out of interest, is it possible to update packages on the NAS by unpacking the files to the admin share and copying that into /sysvol/.PKG/? if so, what tools can open zpkg archives on linux desktop, anyone know? thanks! if this is impossible because they need to be installed on the box, is there a way to install zpkg archives with the command line on the box? thanks.
  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    removing the cloudagent package gives me more errors in console. not sure if this is interesting or not?

    but the first error with cloudagent package ENABLED (!) links to this. does this help anyone to understand the problem please?




  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    edited August 24
    final error i'm seeing is in this:

    Ext.define('MyDesktop.DownServicePref', {<br>&nbsp;&nbsp; &nbsp;extend: 'Utility.SubWindow',<br>&nbsp;&nbsp; &nbsp;id:'downPrefWin',<br>&nbsp;&nbsp; &nbsp;requires: [<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; 'Utility.Ajax',<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; 'Utility.MessageBox',<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; 'Utility.ShareBrowserWin'<br>&nbsp;&nbsp; &nbsp;],<br>&nbsp;&nbsp; &nbsp;toolBarBtns:[{<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; text:'Apply',<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; fn:function(btn){<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; var currentActiveItem = Ext.getCmp("downPrefWizardCard").getLayout().activeItem;<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; if(this.isValidate(currentActiveItem.id)){<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; this.setAllData();<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; }<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; }<br>&nbsp;&nbsp; &nbsp;},



    Im not sure which error is actually the problem halting the page!
  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    chromium shows more errors than firefox



  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    tried again disabling every package except FFP, for reasons explained above, afraid of losing access.

    here's where UI seems to be failing. can anyone decipher this please?




  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    edited August 25
    i'm suspicious of this cloudagent package.
    although Ive delete it from /sysvol/.PKG, it hasn't disappeared from the installed.list or installed folder on samba, and what's this?



    edit: yeah! it's reinstalling the cloudagent into .PKGs. im wondering if blocking the box from internet on my router might help?!

    edit2: tried blocking box from internet, didn't immediately fix problem but i really wonder if this cloudagent is the issue.
  • AlexSA
    AlexSA Posts: 26
    First Comment
     Freshman Member
    zypkg.log ends like this

    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_get_installed_pkg_info][2438][ffp] strValue: "0.7zypkg005"
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_list_zypkg_newVer_contents][1346][ffp] Installed version: 0.7zypkg005, conf version: 0.7zypkg005
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_serialNo_comparison][1313] conf No: 005, Installed No: 005
    2022-08-25 00:43:13 [ipkg][newver][5945]: ********* [zypkg_list_zypkg_newVer_contents][1336][gallery] start listing package "gallery" *********
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_get_installed_pkg_info][2420] open "" failed
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_list_zypkg_newVer_contents][1340][gallery] No Installed version, conf version: 3.0.9zypkg003
    2022-08-25 00:43:13 [ipkg][newver][5945]: ********* [zypkg_list_zypkg_newVer_contents][1336][myZyXELcloud-Agent] start listing package "myZyXELcloud-Agent" *********
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_get_installed_pkg_info][2408][myZyXELcloud-Agent]strControlFile = /i-data/099df5e4/.PKG/myZyXELcloud-Agent/zypkg_conf/info/myZyXELcloud-Agent.control
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_get_installed_pkg_info][2438][myZyXELcloud-Agent] strValue: "1.0.5zypkg0105"
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_list_zypkg_newVer_contents][1346][myZyXELcloud-Agent] Installed version: 1.0.5zypkg0105, conf version: 1.0.5zypkg0105
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_serialNo_comparison][1313] conf No: 0105, Installed No: 0105
    2022-08-25 00:43:13 [ipkg][newver][5945]: ********* [zypkg_list_zypkg_newVer_contents][1336][ownCloud] start listing package "ownCloud" *********
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_get_installed_pkg_info][2420] open "" failed
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_list_zypkg_newVer_contents][1340][ownCloud] No Installed version, conf version: 7.0.15zypkg004
    2022-08-25 00:43:13 [ipkg][newver][5945]: ********* [zypkg_list_zypkg_newVer_contents][1336][pyLoad] start listing package "pyLoad" *********
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_get_installed_pkg_info][2420] open "" failed
    2022-08-25 00:43:13 [ipkg][newver][5945]: [zypkg_list_zypkg_newVer_contents][1340][pyLoad] No Installed version, conf version: 0.4.9zypkg003
    2022-08-25 00:43:13 [ipkg][newver][5945]: [ipkg_cmd_exec][3097] finish "ipkg_cmd_exec" with return value 0
    2022-08-25 00:43:13 [ipkg][newver][5945]: [ipkg_op][892] clear pid file (11: newver)
    2022-08-25 00:43:13 [ipkg][newver][5945]: [ipkg_op][928] ******** ipkg end with return value "0"


  • ariek
    ariek Posts: 27
    Second Anniversary
     Freshman Member
    If an official Zyxel package doesn't install correctly (i.e. aborts or hangs during the installation process) or the web gui won't open after a (apparently) successful installation then you've downloaded and installed the wrong package. The downloaded package doesn't match with your device and/or firmware version.

    I had a similar issue on a NAS520 device where I could not install the NFS package or reinstall the PHP-MySQL-phpMyAdmin package.
    I learned that Metarepositiory didn't download these packages from the official Zyxel ftp servers.
    <div><br></div><div><span># Official repository<br>ftp2.zyxel.com/+ ZyXELmirror<br>#Zyxel Global mirror<br>ftp.zyxel.com/+ ZyxelFTP</span></div>

    (I guess these entries don't resolve properly. The Zyxel ftp site (ftp.zyxel.com or ftp2.zyxel.com) only offers NSA326, NAS540 and NAS542 and I use a NAS520. Obviously, the NAS520 packages are exactly the same as packages for the NAS540. Apparently MR can not find "NAS520 packages" )

    My fix
    I downloaded all the official packages for my device and firmware version (NAS520|fw v5.21, using the NAS540 packages) and uploaded them to my device and added the file location to MR.

    <div><span># Local repository<br>/i-data/b14a6a95/admin/backupzpkg/ Local_backup_ftp_zyxel_com<br></span></div><div></div>
    /i-data/<unique number>/admin/<backup directory>


    Problem solved. All packages are (re)installable again.







Consumer Product Help Center