NR2101 IP Pass-through

Brackan
Brackan Posts: 8
First Comment Friend Collector
edited December 2022 in Mobile Broadband
I recently bought an NR2101 and configured the device to work in pass-through mode by configuring NAT Settings -> IP pass-through. I am not getting the expected behavior from the router though. I am still getting a DHCP address from the LAN Settings page on my clients and if i disable the DHCP server i do not get any IP adress.

Zyxel Firmware version
V1.00(ABUS.4)C0
Software version
RXLG1.27.00.232_0R03
MiFi Software version
AXDG1.27.00.194_0R03

All Replies

  • tonygibbs16
    tonygibbs16 Posts: 610
    25 Answers 500 Comments Friend Collector Second Anniversary
     Guru Member
    edited December 2022
    Hello @Brackan

    What is the expected behaviour that you think that the NR2101 should provide in IP Passthrough please?

    The user guide at https://spdl.zyxel.com/NR2101/user_guide/NR2101_V1.0,%20Ed2.pdf says in section 8.2 that "IP Pass-through allows a LAN computer on the local network of the NR2101 to have access to web services using the NR2101's public WWAN address. When IP Pass-Through is configured, all traffic is forwarded to the LAN computer and will not go through NAT."

    I think that DHCP would not be applicable in IP Pass-Through, because the LAN computer would have the public WWAN address. You probably have to disable DHCP and manually configure the LAN computer with the public WWAN IP address and netmask to access the NR2101 in IP Pass-Through.

    If you need DHCP, then I think that you cannot use IP Pass-Through.

    OR you need to have the NR2101 in IP Pass-Through connected to another Router that does DHCP and NAT for your LAN.

    e.g.
             Cellular WWAN <-> NR2101 in IP Pass-Through <-> Router <-> LAN

    I hope that this is helpful.

    Kind regards,
         Tony
  • Thanks for the answer @tonygibbs16

    You are describing my expected behavior.

    Currently when I put the device in IP pass-through I get IP addresses assigned by the NR2101  DHCP and the clients are NATed.
    If I disable the DHCP server i get no address assigned to clients on LAN.

    My conclusion is that the IP pass-through is not working.
  • A picture showing actual and expected behavior.
  • I have the same issue and am interested in a solution.

    I want to use the NR2101 more ore less as a 5G-Modem and connect it via LAN-Cable to the WAN-Port of my Rounter (a Fritz!Box 7590). On the Fritz!Box I use DynDNS to be able to acccess my Network from the internet.
    But the Fritz!Box publishes the local IP-Adress (e.g. 192.168.225.51) and not the WAN-IP-Adress that is assigned to the NR2101.

    Thats really not what is expected, when selectipn "IP Passthrough", and this was one of the reasons for which I chose the NR2101.

    By the way, the Labeling of the Buttons is really strange... The Buttons (e.g. for "IP Passthrough") is labeled "Activate" when the Option is Activated... So you have to click "Activate" to deactivate this setting. And then the Button is lables "Deactivate" (although it IS deactivated). This is really bad UI-Design, you are never really sure what the current state is and what action you perform, when clicking the Button. Honestly, I was only sure that I am using it correctly, because the other NAT-Options are not editable as long the Button says "Activate".... (BTW: I was first using the German interface where is is similar "Aktivieren" and thought it was just a bad translation, but no... it's just as bad as the Engish version).
  • Is this just a user community or does Zycel participate as well? I'd really like to get a profound response from an expert....
  • martiko
    martiko Posts: 3
    First Comment
    Hi,
    any news on this?
  • Brackan
    Brackan Posts: 8
    First Comment Friend Collector
    Good morning @martiko

    Yes, I have some good news. I got an update from the Zyxel support that solved the issue for me.

    The way NR2101 works is that it will bind the first device that connects after setting IP Pass-through in the settings UI. The binding seems permanent, even if you disable pass-through and enable it.

    What solved the issue for me was to factory reset the device. Connect the client I wanted pass-through to work for, and with that client enable pass-through in the UI.

    I hope this helps!

    /A
  • abel_33450
    abel_33450 Posts: 3
    First Comment

    @Brackan, i tried your suggestion and indeed, the NR2101 modem exposes the IP of the first machine to connect when it should expose the IP provided by the ISP on the WAN side. The issue is that you cannot enable IP-passthru from the built-in screen (you must connect a device to access the GUI and therefore it gets the wrong IP). Conclusion : i can't enable DDNS which was my main reason for selecting this modem…

Consumer Product Help Center