Is the NAS326 now obsolete - I only bought a month ago

Hello - I’m not sure if I have bought a piece of rubbish or not - or maybe more likely I don’t understand how to set up my NAS 326 correctly.

I bought it about 1 month ago and the firmware is up to date.

The problem is this my LAN refuses to see it unless the SMB 1 client in windows is on and of course SMB1 is an App non grata with windows 10 and every update the SMB 1 client is switched off and Win 11 if I decide to upgrade doesn’t even support it.

Also my "shares" are refusing to connect saying that "the device is not functioning."

I’ve tried turning on various features in Win 10 to no avail including SMB direct. Also I've tried rebooting the device, the router and the client - no luck.

Is there a desktop client for the device?

On the same LAN I also have an Asustor 1002T - it suffers no such problems.

All suggestions gratefully received.


All Replies

  • okimarukas
    okimarukas Posts: 86
    First Answer First Comment Friend Collector First Anniversary
     Ally Member
    edited January 3
    The latest version of the NASsupport SMBv2 or SMBv3, maybe you can check the client, if it prefer to use the SMBv1 when doing negotiate.

Consumer Product Help Center