NSA310 spare parts and are the NSA310 disk is readable on NSA320



Yesterday I had a problem and when I took my nas to local shop for fan cleaning the guy had dropped the unit and the plastic piece interfacing with the hard disk was splir from the PCB. TRied to solder but have some problems, namely,

the HDD status lights are nor blinking anymore and they are on solid.

I've got the following message when I tried to reach the interface from google chrome:


Unsupported protocol
The client and server don't support a common SSL protocol version or cipher suite.


Any chance to reach such piece? I know the device is out of date and it is a slim chancebut still some 32x series are available. Can I read the disk on the 32x series or do you recommend me to copy the files to another media and try swapping?

Thanks for the advice

All Replies

  • Mijzelf
    Mijzelf Posts: 2,607  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Your Chrome error is unrelated to the hardware damage. It's just that the old webserver in the box uses a meanwhile deprecated encryption for https. It might work if you explicitly use http:// instead of https:// (Chrome uses https if you don't specify anything).

    If you enabled ‘automatic redirect to https' on the NAS, this won't work. In that case you'll have to create an exception in Chrome to allow older ciphers for the NAS.

    Any ‘firmware 4’ NAS from ZyXEL should recognize and accept that disk, that are all NSA2xx and NSA3xx devices. The NAS326 is a ‘firmware 5’ device, and won't accept the disk as-is.

    Do you know if the disk itself survived the drop?

  • Musashi
    Musashi Posts: 2
    Friend Collector First Comment

    Thanks Mijzelf, luckily I kept the disk home and it had survived the disaster. I try to backup the data and see if it is doable, if done, nothing to worry about than. What do you think?

Consumer Product Help Center