1 disk RAID failed in NSA320S

Options
Norbi
Norbi Posts: 18  Freshman Member
First Anniversary 10 Comments

Hello,

I have a NSA320S (Firmware: V4.70(AANV.0)), I had some hard times with it, but Mijzelf always helped.
So now, after a power failure it cannot boot, no sign of life.

I've removed the disk (4TB Seagate) and plugged it into a Rasberry PI via USB adapter. Previously I had HDD problems, so I made notes, how to mount this type of HDD into linux on RPi, so I started with:

$ sudo fdisk -l /dev/sdb
Disk /dev/sdb: 1,7 TiB, 1801763774464 bytes, 3519069872 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device Boot Start End Sectors Size Id Type
/dev/sdb1 1 4294967295 4294967295 2T ee GPT

This is weird, because last time it reported 2 devices: sdb1 & sdb2

In my notes, the next command is:
$ sudo mdadm --assemble --run /dev/md0 /dev/sdb2

it also not works, because of missing sdb2 device.

I also tried this:
$ sudo mdadm -E /dev/sdb
/dev/sdb:
MBR Magic : aa55
Partition[0] : 4294967295 sectors at 1 (type ee)

$ sudo mdadm -E /dev/sdb1
mdadm: cannot open /dev/sdb1: No such file or directory

After this failed attempts I've plugged the disk into a Win11 machine to watch the partition tables.
It shows 2 partitons: a 487 MB and a 3814959 MB one. The disk contains a Guid Partition Table (GPT).
I've tried a disk recovery software, too, it can show my files in bulk (without the directory structure), so it is nearly useless.

Is it possible to fix it to use the NAS again?
I thik this is my last effort to exted my Zyxel NAS' lifetime :-(

Thank you!

All Replies

  • Mijzelf
    Mijzelf Posts: 2,642  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    I think your SATA-USB convertor doesn't support disks >2TiB.

    Disk /dev/sdb: 1,7 TiB, 1801763774464 bytes, 3519069872 sectors

    4TB equals 3.64TiB. So if the size 'wraps' at 2TiB, it will show up as 1.64TiB. Possibly rounded to 1.7TiB.

    The partition table fdisk shows is the protective MBR table, possibly because your fdisk doesn't support GPT (in that case you are running an old OS on your RPi, possibly because the GPT table is clearly wrong, as it describes a 4TB disk.

    Does you NAS also not boot without disk inside? If you have the possibility you could try another power supply.

  • Norbi
    Norbi Posts: 18  Freshman Member
    First Anniversary 10 Comments
    Options

    Thanks Mijzelf, you saved my day, again!

    When I tried to power on without HDD, I've realized, that the top led is blinking for a minute or two and then stays on, but I cannot find the device in my local network.
    When I tried to pull & plug the power cord, I saw the network cable is loose in the router :-)

    So it was worked all the time, but a loose cable made me a fool.

    OK, it is working fine now, but it is very strange, that now I cannot mount this HDD into the RPi last time I did.
    Now I'm very confident, that I must change before I lost all my data.

    Thank you again!!!
    Norbert

Consumer Product Help Center