NR2101 Borked?

Options
eableson
eableson Posts: 1
edited January 4 in Mobile Broadband

A bit of an odd one here. I just got a new NR2101 that came with an older firmware: V1.00(ABUS.2)C0, Software version RXLG127.00.232_0R03.

When I put in an SFR France SIM (I've tried two), it goes into an endless interface boot cycle (not a full power-on reboot). I observe that the SIM icon shows up with an x to the right of it, then shows full bars, then the screen goes all white, and the cycle starts over, all in the space of about 3-5 seconds and never stops until I turn the device off.

So I wanted to upgrade the firmware which I can't do online and found the following troubleshooting page: https://support.zyxel.eu/hc/en-us/articles/4404106191890-NR-5G-Series-Basic-Troubleshooting#h_01FB6NQ64B3V98J5A134KK10K0

This page include the following Dropbox link (seriously Zyxel?): https://www.dropbox.com/s/ohue7spm3t1ab0k/NR2101_2C000_3C000.zip?dl=0

But when I boot the NR2101 without a SIM and connect to it over the ethernet port and try to upload this file, it never uploads the file. Inside the zip file is a full on file system, and there is no .bin file as referenced in the article. I tried renaming the zip file as .bin and discovered that the web upload doesn't accept .bin files anyway. 🙄

So two questions:

  • Does this model work with SFR SIMs? Or Free.fr SIMs?
  • How can I upgrade the firmware? Or where can I download the firmware for an offline upgrade?

Side notes:

  • I have done a factory reset several times with the same behavior

All Replies

  • Friday
    Friday Posts: 68  Ally Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @eableson,

    May you share what error message pops up or provide a screenshot of saying can't do firmware upgrade online?

    thank you!

Consumer Product Help Center