NR7101 low speed - unable to fix

slaboure
slaboure Posts: 3
Friend Collector First Comment
edited January 4 in Mobile Broadband

Hello,

TLDR: Despite latest firmware and proper debugging and I'm not getting speed higher than 90MB/s on my NR7101 when my iPhone is getting speed higher than 500MB/s at the exact same spot.

On the NR7101:

  • has V1.00(ABUV.8)C0 and RG502QEAAAR13A02M4G (various versions didn't change behavior)
  • Tried to do a factory-reset config in case stream of firmware updates had messed things up
  • Only change to default config is moving to routing mode (vs. IP passthrough)
  • APN configuration well taken from SIM card, similar to phone, etc.
  • Checked with Swisscom that SIM card has no limitation - it is part of the same subscription as the iphone
  • Current 5G status attached
  • behavior has been there for >1 year - so not a one-time issue

iPhone:

Any idea how I can solve this? I went through all ZyXEL support campus articles I could find but none of them solved it

Thanks,

sacha

«1

All Replies

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited July 2023

  • monstrmprz
    monstrmprz Posts: 27  Freshman Member
    10 Comments Friend Collector

  • monstrmprz
    monstrmprz Posts: 27  Freshman Member
    10 Comments Friend Collector

  • monstrmprz
    monstrmprz Posts: 27  Freshman Member
    10 Comments Friend Collector
    edited July 2023

    The nr7101's speedtest is useless use ookla's there too. Try disable B1, B28 bands in the settings and try again. Network setting - Broadband - Cellular Band

    My enabled bands:

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited July 2023

    SINR only 6, maybe a bit low

    Pointing it exactly to the cell?

    Check also this!

  • slaboure
    slaboure Posts: 3
    Friend Collector First Comment

    monstrmprz, thanks for the feedback

    I did as you suggested and tried to play with which B* band was left but nothing improved - same type of bandwidth range. BTW, I saw two empty answers from you before this one, was that by design or is this a bug of the website?

  • slaboure
    slaboure Posts: 3
    Friend Collector First Comment

    Good idea SELBERG, I checked and we are at Full gigabit.

    6 is a bit low, went up to 12'ish but had no impact. I could stay at 12 (would need to move antenna) but isn't the priority as it can't seem to get higher so problem is somewhere else it seems.

    Thanks

  • monstrmprz
    monstrmprz Posts: 27  Freshman Member
    10 Comments Friend Collector

    Bug. When i write on phone, this happens. Very annoying when you write a long comment and when you post the comment the text is disappeared…only works from phone when desktop mode is enabled

  • SELBERG
    SELBERG Posts: 265  Master Member
    First Anniversary 10 Comments Friend Collector First Answer

    If you start writing on line 2, the text remains. Now I'm writing from my android....

  • monstrmprz
    monstrmprz Posts: 27  Freshman Member
    10 Comments Friend Collector
    edited July 2023

    Really! Does it work with messages too?

Consumer Product Help Center