NR7101 5G speed

Options
danielruppen
danielruppen Posts: 10
Friend Collector First Comment
edited January 4 in Mobile Broadband

Hi

I use a NR7101 with the following settings:

Firmware: V1.00(ABUV.8)C0
Module version: RG502QEAAAR11A03M4G
Cellurar Band: Auto
Band Auto selection
IP Pass Through Mode

On the system info page it states %G connection

My issue is speed. Regardless whether I run the speed test on the NR7101 or on my router Unifi dream machine pro, I never get more than 90 Mbits

However if I run a speed test with an Android or iPhone (e.g. iPhone Pro 13) I easy get 300Mbits download speed

Has anyone experienced the same and is there a solution?

Many thanks

Daniel

«1

All Replies

  • Friday
    Friday Posts: 73  Ally Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @danielruppen ,

    Are you using NR7101 speedtest function on GUI or a Ookla speedtest?

    And both Zyxel and Unifi has the speed issue mentioned?

    thanks!

  • danielruppen
    Options

    Hi
    I use the 7101 speed test on the GUI, Oakia and also the Unifi speed test

    On my iPhone I use Oakia spehd test only

  • tonygibbs16
    tonygibbs16 Posts: 902  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    edited July 2023
    Options

    Hi @danielruppen

    It might be worth you upgrading your module version, to at least R11A07 using the modem code files (also known as DFOTA files) available at https://support.zyxel.eu/hc/en-us/articles/4403365084818-5G-Devices-Advanced-Downloads-Firmwares-and-other-resources-

    as that might improve your performance.

    The R13A02 module software then includes 5G Channel Aggregation as one of its changes.

    Kind regards,

    Tony

  • monstrmprz
    monstrmprz Posts: 28  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Update the module firmware and i'm sure that the iphone using different bands than the router. Try enable/disable bands. Navigate to cellmapper.net website to see the 4G/5G bands on your location with your provider.

    Noob question: isn't there a cat5 or older cable after the nr7101, right?

  • danielruppen
    Options

    I've tried that but unfortunately it didn't help. Many thanks for the module upgrade hint

  • danielruppen
    Options

    It's a standard cable, assume it's CAT5. Do you think it could be the cable?
    Re bands: thanks, I've just checked and it tells me 3,20 but I'm a bit lost to set this parameter. It's in Network settings→Cellular Lock (5G), right but do I have to set now? Enable PCI? and then?

  • danielruppen
    Options

    Hmmm, your question re CAT cable let me check my PEO Injector which is very old and I don't have the specs. I have now ordered a new one with enough power and Giga throughput. It will arrive on Monday and I will test and revert back

  • SELBERG
    SELBERG Posts: 297  Master Member
    Community MVP First Anniversary 10 Comments Friend Collector
    edited July 2023
    Options

    Check this!!!

  • monstrmprz
    monstrmprz Posts: 28  Freshman Member
    First Anniversary 10 Comments Friend Collector
    edited July 2023
    Options

    Check what SELBERG said. You need Gigabit connection to earn more speed than 100Mpbs. If you have a device In your network (switch, POE injector or an old cable, that only support Fast ethernet (100Mbps)), the speed will be slow (Max ~90-100Mbps). The unifi is support gigabit so you need check what devices/cables are between the nr7101 and unifi. Anyway what show the unifi to the link speed in your settings? Gigabit?

    If the link is 1Gbps:

    Try enable/disable different bands also in the settings and try again. Try the bands that are available at your location. Network setting - Broadband - Cellular Band. Turn off auto selection and play with bands.

    I've seen CAT5 cable that only support 100Mbps. You need min. CAT5e. The CAT5 is support gigabit in few meters too, but long cables surely not support.

    I hope the new POE Injector is solve your problem!😊

Consumer Product Help Center