Backup to remote FTP server failed

Options
Joopjr
Joopjr Posts: 9  Freshman Member
First Anniversary First Comment

I own an ZyXEL NAS542 and I'm trying to create a backup of the data on the ZyXEL nas to a remote Synology nas. The ZyXEL nas is at my house and the Synology nas is at a other physical location (and therefore has a different public IP address).

Enabling and testing FTP
I've enabled FTP on my Synology nas and tested this. I can connect to the Synology nas using commands in a Linux Terminal at home. I also can connect to the Synology nas with the Linux file explorer Nemo.

joop@LAPTOP:~$ ftp backup@IP.IP.IP.IP
Connected to IP.IP.IP.IP.
220 JOOP-SYNOLOGY FTP server ready.
331 Password required for backup.
Password:
230 User backup logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

Setting up the backup
I've gone to "backup planner" and added a new Job. I select a "Remote" destination and filled in the same IP address, Username, Password and Share name that I used during my terminal testing. It shows an error that the username and/or password is incorrect. But I'm 100% sure that those are correct.

Running the backup
I actually created the job and tried running it. The backup planner throws the error "Failed, Cannot connect remote target". This implies that the whole FTP connection is not established.

The log (under settings → maintenance) shows the error "Cannot mount remote share". This however implies that FTP did connect but mounting the drive failed.

Testing FTP
I wanted to test some more and decided to use the "Upload manager" to test the FTP connection. I added the same remote FTP server and this time I get a confirmation about the connection very quick.

I added a folder to the watch list to test if uploading files worked. I then added a file to the watched folder and this was uploaded (after the grace period ended) to the remote Synology nas.

The "Upload Manager" only uploads new files. It doesn't upload existing files prior to setting up the "upload manager", it also doesn't upload changed files. Therefore this doesn't fix the issue that I want a backup of all my data.

Question
I do understand that both devices aren't from the same brand. I'm however using FTP which is supported by both devices. I want to backup my data at home (ZyXEL nas) to a remote location (Synology nas), I don't care how it's done but assumed FTP was the easiest option.

Why is the backup manager not working? How do I fix this?

(I've replaced the real IP with ip.ip.ip.ip)

All Replies

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    In your screenshot it's not visible that your backup peer is supposed to be an FTP server. Is it specified somewhere?

    I never used the backup planner, but I vaguely remember that is only works with zysync, which is a (slightly?) modified version of rsync.

    If you are comfortable with scripting, you could write a script using find and curl to do the upload task. The Tweaks package can inject the script to the firmware cron, so it's executed automatically.

  • Joopjr
    Joopjr Posts: 9  Freshman Member
    First Anniversary First Comment
    Options

    I never thought about the fact that external backup could be done any other way than FTP. I had blindly assumed that the FTP protocol was used.

    The help page states:

    It doesn't mention anywhere whether it uses/not uses FTP. I do notice now that it's talking about another NAS within the network.

    I have successfully used rsync from a Linux laptop to my external Synology NAS. However, the backup scheduler is not usable because the username cannot be changed (it must be admin), and the password allows only 14 characters.

    I also tried to get rsync working via the command line (SSH). However, the command is not recognized. The Zyxel NAS runs BusyBox which doesn't include rsync.

    sh: rsync: not found

    Anyone any suggestions on how to backup my Zyxel NAS? I am leaning more and more towards replacing it, I am spending a huge amount of time looking for a solution without success.

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    My RandomTools package has an rsync binary.

Consumer Product Help Center