NR7101 IP addresses 192.168.2.x

fozzie
fozzie Posts: 2
First Comment
edited January 4 in Mobile Broadband

I have just bought the NR7101, and need to use it in router mode, so have set IP passthrough to no. I have configured the LAN page to use 192.168.1.254/24 as the LAN address, and .100 - .200 as DHCP. When devices connect through the ethernet port, they get IP addresses from the subnet 192.168.2.x. Devices that connect through wi-fi, get addresses from 192.168.1.x.
As the router needs to integrate with existing network config, I do need to use 192.168.1.x. I have downloaded and tried v6, v7 and v8 firmware, and all the same.
I then downloaded the config, opened it with gedit, and looked for 192.168.2. config, modified the 192.168.2.x places to 192.168.1.x and uploaded it, and now the router is using the 192.168.1.x as I require it, although the LAN config page does not show that network (I set it to 192.168.100.x, just to see what happened).
There seems to be something going wrong when using the NR7101 in router mode - I did look into setting a new interface group, but there was no LAN option, so could not do it.
what do I need to do, to get the NR7101 to work in router mode, using the subnet of my choice, without "hacking" router config file?

All Replies

  • I think you should connect your computer to the NR7101 router either via Ethernet or Wi-Fi, and open a web browser. Enter the default IP address of the router (e.g., 192.168.1.1) in the browser's address bar and press Enter. This should take you to the router's login page.

  • autom4il
    autom4il Posts: 2
    Friend Collector First Comment
    edited January 30

    Hi @fozzie, I'm having the same exact issue. I have set the DHCP router to release IP addresses in the space 192.168.1.100-200 while I keep the default router interface available at 192.168.1.1. Why the address assigned to my devices are in the subnet 192.168.2.* and not 192.168.1.*? Looks like to me the same subnet configured on "bridge1" when going to "Home Networking → Interface Group → Group Name → Bridge1". This looks to me like a bug, by the way did you solve it?

    Now it's in "Router Mode" with "IP Passthrough" disabled.

    EDIT:
    Nice, looks like there is no way to contact support. I guess the first thing I'll do is send it back…

  • fozzie
    fozzie Posts: 2
    First Comment

    @autom4il You are right about the lack of support on here…

    Yes, I have it all working well, after downloading the config file, opened it, and looked for entry for 192.168.2. config. I modified the 192.168.2.x places to 192.168.1.x and then uploaded that fileback on to the box, and now the router is using the 192.168.1.x as I require it, although the LAN config page does not show that network.

    All a bit messy, but it does work well - I'm in a rural location getting 100Mbps+ over 5G, with no real alternative, but certainly a bug that I hoped support would have picked up on. I had the 4G version up for a number of years, so the hardware is good, just a shame they don't seem to care about bugs!

  • autom4il
    autom4il Posts: 2
    Friend Collector First Comment
    edited January 30

    @fozzie same here, the only decent way for me to have a good broadband is to use the Zyxel external antenna though I have used Mikrotik and their RouterOS is amazing unfortunately they only have an indoor router.

    Is here any employee from Zyxel we can tag to report this behaviour to?

    Anyway my personal thought since nothing is reported in the manual I guess is that the “Default” profile, lets call it this way, is only used for access the router settings(I know it sounds crazy). However, having changed the “Bridge1” profile it works just fine the DHCP releasing IPs in the correct space.

    Thanks a lot for answering back, strange that no one have reported this before. Let’s hope for someone knowing the fact to answer back as well.

  • Noddy
    Noddy Posts: 47  Freshman Member
    First Anniversary 10 Comments Friend Collector First Answer

    Pinged you a message @autom4il.

  • Internetheavyuser
    Internetheavyuser Posts: 65  Ally Member
    10 Comments Friend Collector First Answer

    Hi @fozzie,
    Can you print screen Newwork Setting → Home Networking (As the picture below)
    Also Newwork Setting → Interface Grouping

    And System info

    Because which WAN you use will lead to which interface group you use.

    And the end will lead to which Home Networking setting you use.

    If you dont set the 192.168.1.X in all the Home Networking setting. It would be weird to get the IP with 192.168.2.X


Consumer Product Help Center