Nebula wax620d-6e 2.4Ghz issues

Options
Fadhil
Fadhil Posts: 12
Friend Collector First Comment

I have zyxel AP WAX620D-6E running the last firmware (v 6.70(accn.1) and linked to my site.. The problem is that I can't get 40 mhz bandwidth in the 2.4Ghz , when I set it to 40 mhz I get 573 Mbps connection speed but after few minutes It goes back to 20 Mhz with connection speed of 286 Mbps (Although it is still 40 mhz in settings but it actually transmits at 20.)

There is no channel congestion and the frequency used is quite clean when checked in Wifi man or scanned in MikroTik router..

For your kind help

Accepted Solution

  • Zyxel_Kay
    Zyxel_Kay Posts: 557  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Hi @Fadhil

    I've just realized that the command I provided earlier is intended for AP operating in standalone mode, and may not work for your 2.4GHz radio profile when the AP is operating in Nebula cloud mode. In Nebula cloud mode, the radio profile for 2.4GHz is RADIO_SETTING_TYPE_2, while for 5GHz, it's RADIO_SETTING_TYPE_5.

    Please follow the steps below and update the command in Step 6 to configure the 2.4GHz radio profile:

    • Router# configure terminal
    • Router(config)# wlan-radio-profile RADIO_SETTING_TYPE_2
    • Router(config-wlan-radio default)# dot11n-disable-coexistence
    • Router(config-wlan-radio default)# exit
    • Router(config)# write

    If successful, in Step 7, you should observe part of the result in ap profile: RADIO_SETTING_TYPE_2 displaying:

    • Channel_width: 20/40
    • Dot11N_DisableCoexixtence: yes

    Regarding your request, we will raise it as a feature request: Provide 20MHz, 20/40Mhz, and 40MHz bandwidth options for the user to choose according to their usage scenario. When selecting 40MHz, it should force AP 2.4GHz to use 40Mhz (802.11n coexistence disabled). You can find it in the idea section:

    Kay

All Replies

  • Zyxel_Kay
    Zyxel_Kay Posts: 557  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Fadhil

    To gain a deeper understanding of your condition, we would appreciate some additional details. Specifically, could you clarify the following:

    1. When you mention the connection speeds of 573 Mbps and 286 Mbps, are these the data link speeds shown on your device, or are they internet speed test results?
    2. Could you please provide the model and capabilities of the NIC you're using for these speed measurements?

    Furthermore, could you please enable Zyxel Support on your Nebula and provide us with your org. and site name, so we can directly examine your site settings and event logs to gain more insights?

    Kay

  • Fadhil
    Fadhil Posts: 12
    Friend Collector First Comment
    edited January 16
    Options

    Hi Kay

    Thank you for your Reply

    1. 573 is the link speed shown in my device.
    2. I have an android device and it shows the link speed of every wifi access point it connects to.

    Organization " Fadhil Al-Helali"

    Site " Home "

    Invited zyxel support and looking forward for your help.

  • Zyxel_Kay
    Zyxel_Kay Posts: 557  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Fadhil

    Upon reviewing your Nebula site, we noticed that the channel width for your WAX620D-6E is currently locked to 20 MHz. To achieve the desired 40MHz channel width, please reconfigure the radio settings at Site-wide > Configure > Access points > Radio settings > scroll to the bottom of the page.

    Feel free to reach out if you encounter any issues or if you have further questions.

    Kay

  • Fadhil
    Fadhil Posts: 12
    Friend Collector First Comment
    Options

    Hi @Zyxel_Kay

    Thank your for reviewing my site

    yes I made it 20 mhz because whatever I choose it actually transmits at 20 mhz.

    Now I made it 40 Mhz in the settings but it actually transmits at 20 mhz.

  • Zyxel_Kay
    Zyxel_Kay Posts: 557  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Fadhil

    Thanks for sharing the latest update of your radio setting. After remotely accessing your AP, we've observed that your AP's 2.4GHz radio is currently operating on a 20MHz channel width.

    It seems that there might be some devices in your environment that only support a 20MHz channel width. To ensure compatibility with these devices, the AP automatically adjusts the bandwidth to 20MHz.

    If you intend to use a 40MHz channel width on the AP, you can try using the following commands to disable coexistence after configuring the channel width to 40MHz:

    Router# configure terminal
    Router(config)# wlan-radio-profile default
    Router(config-wlan-radio default)# dot11n-disable-coexistence
    dev.wifi1.dcs_manual_ch = 1 0
    Router(config-wlan-radio default)# exit
    Router(config)# write

    (Note: If you reboot the AP, these commands will not be preserved, so you may need to reapply them after a reboot.)

    For more information and discussions related to this topic, you can refer to the following thread:
    Does WAX510D support 40MHz on 2.4G? — Zyxel Community

    Feel free to reach out if you have any more questions or need further assistance.

    Kay

  • Fadhil
    Fadhil Posts: 12
    Friend Collector First Comment
    Options

    Hi @Zyxel_Kay

    Thank for viewing my access point and offering fix to my issue.

    Could you please help me applying these commands.

  • Zyxel_Kay
    Zyxel_Kay Posts: 557  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Fadhil

    Sorry that I forgot to mention that the commands need to be applied before the AP channel width has been adjusted to 20MHz. Due to this, I couldn’t help to configure the setting from my site currently.

    Let me provide more detailed guidance for you to achieve this.

    1. Set your AP channel width setting to 40MHz, and wait for the configuration status on Nebula up to date. (You may skip this step as your current channel width setting for 2.4GHz is 40 MHz)
    2. Move the AP to a clean environment to ensure that it doesn't detect any devices in the environment supporting only a 20MHz channel width and automatically adjust the bandwidth.
    3. Reboot your AP and wait for it to come online in Nebula. Once the AP is online, it will reapply the configuration you set in Nebula.
    4. Connect a PC to the same subnet as the AP, open the Tera Term or Putty on your PC, and establish a connection with your AP to apply the following CLI command.
    5. To double confirm that your AP is running on 40 MHz, you may apply the following CLI command and check for the current channel width setting on AP:
      • Router> show wireless-hal current channel
    6. Once confirmed, apply the following commands to fix the channel bandwidth at 40MHz:
      • Router# configure terminal
      • Router(config)# wlan-radio-profile default
      • Router(config-wlan-radio default)# dot11n-disable-coexistence
      • Router(config-wlan-radio default)# exit
      • Router(config)# write
    7. After applying the command, recheck if the configuration was successful with the following command:
      • Router# show wlan-radio-profile-by-slot slot1
        If successful, you should see a part of the result showing:
        • Channel_width: 40
        • Dot11N_DisableCoexixtence: yes
    8. Now your AP should be running on a 40MHz channel width.

    Please note that if you reboot the AP, these commands will not be preserved, so you may need to reapply them after a reboot.

    Kay

  • Fadhil
    Fadhil Posts: 12
    Friend Collector First Comment
    Options

    Hi @Zyxel_Kay

    Thank you for your great efforts to help me.

    I will provide screenshots to you to explain what happened with me.

    I did exactly what you told me to do and applied all the commands and the access point really gave 40 mhz bandwidth but when checking using the the commands you provided it shows 20 Mhz in one command and 40 Mhz in the other.

    And when I reboot my mobile router (without rebooting the AP)

    the access point went back to 20 Mhz bandwidth.

    Could you please solve the whole issue in the next firmware update and let the user choose either fixed bandwidth according to his selection or letting the access point override his settings and choose the bandwidth automatically when needed.

  • Zyxel_Kay
    Zyxel_Kay Posts: 557  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Hi @Fadhil

    I've just realized that the command I provided earlier is intended for AP operating in standalone mode, and may not work for your 2.4GHz radio profile when the AP is operating in Nebula cloud mode. In Nebula cloud mode, the radio profile for 2.4GHz is RADIO_SETTING_TYPE_2, while for 5GHz, it's RADIO_SETTING_TYPE_5.

    Please follow the steps below and update the command in Step 6 to configure the 2.4GHz radio profile:

    • Router# configure terminal
    • Router(config)# wlan-radio-profile RADIO_SETTING_TYPE_2
    • Router(config-wlan-radio default)# dot11n-disable-coexistence
    • Router(config-wlan-radio default)# exit
    • Router(config)# write

    If successful, in Step 7, you should observe part of the result in ap profile: RADIO_SETTING_TYPE_2 displaying:

    • Channel_width: 20/40
    • Dot11N_DisableCoexixtence: yes

    Regarding your request, we will raise it as a feature request: Provide 20MHz, 20/40Mhz, and 40MHz bandwidth options for the user to choose according to their usage scenario. When selecting 40MHz, it should force AP 2.4GHz to use 40Mhz (802.11n coexistence disabled). You can find it in the idea section:

    Kay

  • Fadhil
    Fadhil Posts: 12
    Friend Collector First Comment
    Options

    Hi @Zyxel_Kay

    I will try this new command for the cloud managed A.P.

    Thank for revising the commands

    And many thanks for trying to adopt my suggestion .I think it will be very helpful to the users.

Nebula Tips & Tricks