zyxel 8-port 2.5g multi-gigabit unmanaged switch

Options
Lefty_Insider
Lefty_Insider Posts: 28  Freshman Member
10 Comments Friend Collector

I have the following product: zyxel 8-port 2.5g multi-gigabit unmanaged switch for home entertainment or soho network

I use it in a network with a Hitron 2.5 Gbps cable modem, Netgear Nighthawk 2.5 Gbps router and this switch. I also have three 2.5 Gbps computers connected to this switch.

To get an IP address from with ISP modem with the router, I must connect it directly.

If I connect the modem port to the switch, and the switch to the router, it will not pass through the ISP IP address.

This is an unmanaged switch so why is this?

Thanks, Lefty

«13456

All Replies

  • PeterUK
    PeterUK Posts: 2,988  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    edited April 23
    Options

    If you have done the following

    https://www.virginmediabusiness.co.uk/help-and-advice/products-and-services/hitron-router-guide/dynamic-modem-only-mode-user-guide/

    You only get one WAN IP by one source MAC if you connect the switch to the Hitron many devices each with its own MAC only one may work this is why you use NAT router.

  • Lefty_Insider
    Lefty_Insider Posts: 28  Freshman Member
    10 Comments Friend Collector
    Options

    I am using a Hitron EN251 which is just a modem. My temporary solution is to connect modem to router and boot router to get a ISP WAN IP.

    Then I connect modem to switch and switch to router. That way i have 2.5 Gbps on my network all the way to the modem which unfortunately, at least for now, has a Spectrum 1 Gbps limit. Router sends DHCP LAN addresses via the switch/router to the clients just fine.

    Works until I reboot the router and then I have to do this setup all over again. What happens is the system after router reboot sets the router to 10.0.0.2 (don't know where this IP comes from) for some unknown reason and I have to go back into the router and fix the IP.

    So I take it that you believe that it is the switch MAC (no PC's connected) that is interfering? Any ideas on how to work around this? Could a managed switch be configured to get around this?

    Thanks for your input,

    Lefty

  • PeterUK
    PeterUK Posts: 2,988  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    How many WAN IP's do you get from the modem?

  • Zyxel_Nami
    Zyxel_Nami Posts: 576  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 25
    Options

    Hi Lefty @Lefty_Insider

    Based on your description, it seems your intended setup is: Hiltron EN251 modem → Zyxel MG-108 switch → Netgear Nighthawk router, however, the Netgear router is not receiving the WAN IP in this setup. To address this issue, we would like to clarify a few points:

    • Router model: please provide the full model names of your Netgear Nighthawk router
    • Router connection: Could you confirm which port on the Netgear router the switch is connected to? Is it the WAN port or a LAN port?

    So I take it that you believe that it is the switch MAC (no PC's connected) that is interfering? Any ideas on how to work around this? Could a managed switch be configured to get around this?

    ⇒ Regarding this concern, MG-108 doesn't have the MAC address itself; it simply forwards packets based on observed MAC addresses.

    Share your now! https://bit.ly/4aO0BMF

    Nami

  • Lefty_Insider
    Lefty_Insider Posts: 28  Freshman Member
    10 Comments Friend Collector
    Options

    Sorry for the delay I was out of town.

    Spectrum will only give you one. I wonder if they would give me two with two port modem, or just the same one on each.

  • Lefty_Insider
    Lefty_Insider Posts: 28  Freshman Member
    10 Comments Friend Collector
    Options

    Nami,

    Router is a Netgear Nighthawk RAXE500 and am plugged into it's 2.5 Gbps port with a Cat 7 cable. Another Cat7 cable from the switch to the 2.5 port on the modem.

    Cat 6 cables (50 feet or so) from the MG-108 switch ports, when I connect them to the switch ports rather than the router ports, to another MG-108 in my office. Network status shows me 2.5 Gbps on my client computers.

    So the question remains, why won't the switch pass though the ISP WAN IP address?

    I thought that all network devices had a MAC address.

    Thanks, Lefty

  • PeterUK
    PeterUK Posts: 2,988  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Options

    As you only have one WAN IP it be locked to one source MAC if you do

    Modem <> switch <> to two devices each with a different MAC only one will work this is why you do

    Modem <> router <> switch

    This allows the router to do NAT to take a 192.168.0.xxx to your one source MAC and WAN IP out the router

    other types of NAT's exist but they are not as simple and have limitations for one WAN IP on a single MAC

  • Lefty_Insider
    Lefty_Insider Posts: 28  Freshman Member
    10 Comments Friend Collector
    Options

    I am waiting for Nami to clarify his statement that the switch has no MAC, and that the switch cannot possibly be interfering.

    We shall see if he has a solution.

    Thanks

  • Lefty_Insider
    Lefty_Insider Posts: 28  Freshman Member
    10 Comments Friend Collector
    Options
  • Zyxel_Nami
    Zyxel_Nami Posts: 576  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Lefty_Insider

    We've conducted a test with a similar setup (ISP modem → MG-108 → USG FLEX 100 Firewall). The firewall successfully received the public WAN IP from the ISP. This confirms that the MG-108 can correctly forward packets based on the MAC addresses it learns.

    To understand better your setup and figure out the cause, let's clarify the following points:

    I am using a Hitron EN251 which is just a modem. My temporary solution is to connect modem to router and boot router to get a ISP WAN IP.

    Then I connect modem to switch and switch to router. That way i have 2.5 Gbps on my network all the way to the modem which unfortunately, at least for now, has a Spectrum 1 Gbps limit. Router sends DHCP LAN addresses via the switch/router to the clients just fine.

    Works until I reboot the router and then I have to do this setup all over again. What happens is the system after router reboot sets the router to 10.0.0.2 (don't know where this IP comes from) for some unknown reason and I have to go back into the router and fix the IP.

    ⇒ Let's double-confirm the steps of your temporary solution:

    1. connect the WAN port of the router directly to the Hiltron modem, the router can obtain a WAN IP
    2. unplug the cable between the modem and the router
    3. connect the modem to the switch, then the switch to the WAN port of router

    ⇒ With this setup, does the router still receive the WAN IP before rebooting?

    After rebooting, the router receives an unknown IP, 10.0.0.2. On which interface does it receive the IP 10.0.0.2, LAN or WAN?

    Router is a Netgear Nighthawk RAXE500 and am plugged into it's 2.5 Gbps port with a Cat 7 cable. Another Cat7 cable from the switch to the 2.5 port on the modem.

    Cat 6 cables (50 feet or so) from the MG-108 switch ports, when I connect them to the switch ports rather than the router ports, to another MG-108 in my office. Network status shows me 2.5 Gbps on my client computers.

    ⇒ For clarity, could you confirm if the following accurately describes your current setup?

    And when you mention that the router can't receive the WAN IP, are you referring to this setup?



    Regarding the MAC address, you can verify by checking the label on the bottom of the MG-108 device; it does not display a MAC address, which is typical for an unmanaged switch. Unmanaged switches like the MG-108 do not manage IP addresses or MAC addresses; they simply forward Ethernet frames based on the MAC addresses they observe from incoming data on connected devices. This design ensures the unmanaged switch merely passes along data without modifying or managing it.

    Share your now! https://bit.ly/4aO0BMF

    Nami