MPro Mesh with EX3301-T0 (ISP) and WX3100-T0

Options
ozanaki
ozanaki Posts: 6
Friend Collector First Comment
edited May 13 in Mobile Broadband

I have an EX3301-T0 router given by my ISP (Turk Telekom - Turkiye).
I wanted to install a Wi-Fi Mesh in the house to extend the coverage area.
So I bought the WX3100-T0 which was said to be compatible with the EX3301-T0.
However, I could not set up and run properly the Wi-Fi MPro Mesh network even though I followed the guides. WX3100 works just like a standalone regular AP.

Situations

  • My EX3310-T0 is never assigned as a Mesh controller.
  • My WX3100-T0 is automatically found and added to the device list, but EX3310-T0 is not listed by the MProMesh Mobile App.

  • EX3301-T0 has an option to enable or disable MPro Mesh but there are not any signs if it works with MPro Mesh properly or not. I could not verify my network working with MPro Mesh except by traveling room by room with a phone. (Never worked as expected)

  • There isn't any bit of information if the EX3310-T0 router's WiFi is working with the MPro Mesh Network or not.

  • The router (EX3301-T0) is presented as the only router without any Wi-Fi functionality in all manuals and quick start guides.

  • I can't figure out if this situation is caused by ISP's firmware.

  • I can't upgrade the firmware because of the ISP-specific device. (There are no firmware update options)

Questions

  1. Why is my EX3301-T0 not listed on the MProMesh Mobile App?
  2. Why is my EX3301-T0 not assigned as an MPro Mesh Controller?
  3. Does EX3301-T0's own Wi-Fi work with MPro Mesh?
  4. How can I verify whether the MPro Mesh is working properly or not?
  5. How can I determine if this situation is caused by the ISP's firmware or not?
  6. If this is caused by ISP's firmware, how can I upgrade the firmware?
  7. If ISP-specific devices do not work with other generic devices, why are these devices named with the exact same model number?

My EX3301-T0 Device Information

Model Name: EX3301-T0
Firmware Version: EX3301-T0-V0.28-20231120
ISP: Turk Telekom (Turkey)

My WX3100-T0 Device Information

Model Name: WX3100-T0
Firmware Version: V5.50(ABVL.4.1)C0

All Replies

  • Liba
    Liba Posts: 117  Ally Member
    First Anniversary 10 Comments First Answer
    Options

    I suggest you contact your ISP provider (Turk Telekom) for assistance.

  • tonygibbs16
    tonygibbs16 Posts: 863  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited May 13
    Options

    Hello @ozanaki

    Welcome to the forum.

    You might have to contact your ISP (Turk Telecom) as @Liba suggests.

    There is also the user guide at https://download.zyxel.com/EX3301-T0/user_guide/EX3301-T0_V5.15_5.70_Ed2.pdf that might help.

    * downloaded from https://www.zyxel.com/uk/en-gb/support/download?model=ex3301-t0

    It says the below in it:

    Kind regards,

    Tony

  • ozanaki
    ozanaki Posts: 6
    Friend Collector First Comment
    Options

    Unfortunately, explaining this problem to the ISP is more difficult than solving it. (all reachable people are only sales and marketing employees) Also, from the ISP perspective, there is no problem if there is an internet connection. It is not possible to reach technical people other than marketing and sales.

  • ozanaki
    ozanaki Posts: 6
    Friend Collector First Comment
    Options

    Thank you for your reply.
    Of course, I have already tried all the instructions written in the manual. Despite these instructions, my router never appears as a Mesh Controller. I think it is caused by the firmware, but since it is an ISP-specific device, the firmware update menu has been removed.

    What confuses me is that the device marked as EX3301-T0 has both a generic version and an ISP-specific version, but devices with the same model number are incompatible with each other.

    Best Regards,

    Ozan

  • ozanaki
    ozanaki Posts: 6
    Friend Collector First Comment
    Options

    The ISP version of the EX3301-T0 device is not compatible with MPro Mesh and didn't work. Do not buy WX3100 devices for planning to set up a Mesh network, it will not work. Don't waste your money and consider using other brands such as TP-Link or others.

Consumer Product Help Center