My NAS326 keeps ssh service enabled with every boot

Options

Hello,

I am using NAS326 and I noticed this - when I turn ssh service off via web gui, the ssh server is correctly unavailable. But when I turn off and on (or reboot) the NAS, the ssh server is again available despite the fact the service is unchecked in the web gui.

I checked the configuration files /etc/zyxel/py_conf and /var/web_framework/py_conf and both of them show the ssh service as "false".

There must be something what keeps turning ssh service on when booting.

I 100% know it worked before, but don't know how long is it it stopped working. I tried to update FW to latest V5.21(AAZF.17) but the problem remains (it's same like in the previous version).

Do you anyone know what script or config keeps ssh service in the OS on independently on the gui config?

Thanks in advance.

All Replies

  • Zyxel_Jerry
    Zyxel_Jerry Posts: 1,198  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @tjenikovsky

    Thanks for the feedback.
    The SSH should be disable after reboot.
    We will check the case, please kindly wait for my update.

  • tjenikovsky
    tjenikovsky Posts: 2
    Friend Collector First Comment
    Options

    Hi @Zyxel_Jerry,

    Do we have any news regards this case?

    Thank you for information.

  • Zyxel_Jerry
    Zyxel_Jerry Posts: 1,198  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @tjenikovsky

    The firmware will not enable the services after reboot.
    Could you disable the function, collect the configuration backup file, then reboot the device and collect the configuration backup file again?
    Please send us both configuration files in a private message.

Consumer Product Help Center