New firmware for Multy M1

Options

Hello

Maybe somebody could know when the newest firmware would be available?

We can find this document, so maybe you know the release date for public?

https://device.report/m/eb406ce9bd5e71061cf6450cbe370af9274653b1144cd9f37f199fcde176d135.pdf

Thanks!

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,927  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @szyper,

    Due to identified issues, version V1.00(ABZF.7)C0 has been removed from the download library and will not be available in the future.

  • szyper
    szyper Posts: 2
    First Comment
    Options

    Ok, thanks,

    any news about plans for newer firmware for this device?

  • Zyxel_Judy
    Zyxel_Judy Posts: 1,209  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @szyper ,

    The Multy M1 (WSM20) is entering its EOL period, so there will no longer be any new firmware updates for this device. The final firmware version is V1.00(ABZF.6)C0.

    You can check the EOL information at this link:

    End of life | Zyxel

    Share yours now! https://bit.ly/4aO0BMF

    Judy

  • redone
    redone Posts: 3
    Friend Collector First Comment
    Options

    OK do You want to tell us that a completely new product, on the market from the beginning of 2022 and You are deleting it from support already in June or the beginning of July… where at least on paper it has support until the end of December? Are you kidding? From Multy X, You suggested migrating to the successor- Multy M1. Now You are closing this product. Completely new equipment, good one… is about to lose support... I don't understand it! Where is logic in this and what are your customers supposed to think about it? Even if support ends because that was planed date, the moment when it ends you should care about making at least the last update and securing the equipment... Because customers expect their routers to be safe. Yes, we can switch to OpenWRT. But I guess that's not how it should be. For example, someone bought a Multy M1 this year. It has half a year of support on peper, where no one cares whether their equipment works. By law, it has a 24-month warranty in the EU. In your opinion, he has no right to feel cheated? I praised Your equipment for quality and comfort. Now I will probably change my mind, this is not how you should treat users of your products.

  • Zyxel_Judy
    Zyxel_Judy Posts: 1,209  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @redone ,

    Thank you for your feedback.

    According to the EOL information, we will continue to support users until 2025-12-31.

    Our previous response was to inform you that there will be no new features or enhancements for Multy M1 as part of our development plan. However, this does not mean that we are stopping support for users.

    Detailed EOL information is as follows:

    • End of Development: 2024-12-31
    • End of Vulnerability Support: 2025-12-31
    • End of RMA & Tech Support: 2025-12-31

    Could you please share with us the issue you are facing or the reason you need firmware newer than V1.00(ABZF.6)C0?

    Share yours now! https://bit.ly/4aO0BMF

    Judy

  • OnnoJ
    OnnoJ Posts: 10  Freshman Member
    First Anniversary Friend Collector First Answer First Comment
    Options

    So my Multy M1 have the firmware version V1.00(ABZF.7)C0 installed. How can I downgrade to the previous stable version?

    The Multi M1s do report in the Multy app that there is a 'new' firmware version available (V1.00(ABZF.6)C0), but when I choose to upgrade (or actually downgrade) the upgrade process seems to start, but at the end the faulty FW-version (V1.00(ABZF.7)C0) is still on the device's...

    Please advise!

    Regards Onno

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,927  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @OnnoJ,

    We can help you to downgrade the firmware. I will DM you to book a remote session for the firmware downgrade operation.

  • redone
    redone Posts: 3
    Friend Collector First Comment
    edited July 24
    Options

    In my opinion, You shouldn't ask what doesn't work, but what we would like to see added. e.g. offline update from a file or via the phone application using LTE or 5G. Adding the option of using shared internet from a phone - hotspot wifi - in case of ISP failure. Adding even a change of mac for wan in the phone application. Adding translations into the languages ​​where you sell your products - Polish, Czech, Slovak. If you need help with translation, ask for it. Someone will be happy to help translate it, maybe they will become a tester in the future. These are the basic things that you can successfully add to this router. Now You have half a year to develop the product, and You already say that the last update will be…October 2023. This is how You force, even push, users to use alternative software such as openwrt.

    And honestly, I would be happy to help test such options because they can be very useful. It won't replace portable routers, but it will add a very useful function - using a wifi hotspot from your phone in case of ISP failure.

    The equipment has a large reserve of power, it can do much more. But Your software is unfortunately very basic. Adding a few simple things, those that are not a problem for the mentioned openwrt... I am sure that for such a specialized company these are not difficult things to add and they would greatly improve the quality of this product. Zyxel would show that the hardware can be developed even after release and that You care about quality and Your customers. But no... Since the V1.00(ABZF.7)C0 update appeared, and many of us have installed this update, it apparently introduced some improvements in functions or software. So I don't understand the approach and how it can be claimed in July 2024 "The Multy M1 (WSM20) is entering its EOL period, so there will no longer be any new firmware updates for this device."
    And as for the problems that should have been removed long ago, these are design errors… You cannot change the mac for wan before logging in to the application, creating accounts, logging in to the panel via a browser... you won't log in to the account, you won't create it, you won't log in to the panel in the browser because you can't change the mac to wan and the internet doesn't work! loop! You have to ask the operator to delete mac wan and will be used the first time you try to log in to their services. This is a loop, that is not comfortable, You have to wait, need to ask the operator and not do it yourself when initially setting up the router. Solution - use an LTE or 5G connection, perform an update, change the MAC WAN in the application, already at the stage of hardware installation.This can be added bundled with wifi hotspot because it directly uses this function. Or allow initial access to the panel in the browser without creating an account, this account and login can be created after the initial setting of mac for wan.

  • OnnoJ
    OnnoJ Posts: 10  Freshman Member
    First Anniversary Friend Collector First Answer First Comment
    Options

    Actually the situation is weird: there is a known issue in the last issued firmware as version 7 is withdrawn and roleback to version 6 is needed, but also version 6 has issues (roaming) and yet it is stated that no new firmware (8?) will be produced.

    I feel I am left with a flimsy product and this is pushing me away from Zyxel, as I cannot trust to have a stable mesh network with the Multy M1. Working from home requires just that - I hate to be disconnected during online meetings.

    I just ordered a new mesh system from TP-link - let's see whether they do better..

  • redone
    redone Posts: 3
    Friend Collector First Comment
    Options

    And that's why I don't understand why they don't care. There are things that can be improved, there are some problems. The last update was released, withdrawn... half a year to the end of the period when they should not only fix bugs but improve the software, add new things, functions... And here's the July news - we won't. They don't care. I don't understand this approach to products, brand and customers. And this at a time when the customer can easily choose another brand, another product. In the past, quality was taken care of, the brand was built and its value was protected. For Multy M1… a year of real support simply does not exist. All of 2024 has been deleted, it's gone! There is not even the slightest update from 2024. And not because the product is without flaws. They just don't care.

Consumer Product Help Center