NAS540 transfert speed ?

Fredzoul1
Fredzoul1 Posts: 97  Ally Member
edited November 2017 in Personal Cloud Storage
Hello,
The speedtest is making on the same network, with the same soft, with the same computer on Win 7, with the same router, with same switch and the same câble on the same port ! 4 similar HDD in every NAS !
First is a QnapTS453mini (last firmware), second is a Zyxel NAS540 (last firmware) - I precise I have two NAS540, the results are the same for Zyxel with the two NAS540.
What the reason of the speed difference ??? Any idea ???
I restart the test many time, with the same result on differents days... and no other traffic on my network. 


#NAS_November

Comments

  • Mijzelf
    Mijzelf Posts: 2,213
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    The NAS540 is not really comparable with the TS453mini. A dualcore Armv7 SoC vs a quadcore Intel, with at least twice the memory. (according to this specs). The QNAP is much more powerful.

    Having said that, your 540 is surprisingly slow. I can saturate my network with my 540. Maybe you should have a look with 'top' or 'htop' to see if something is eating all CPU cycles during the test.
    It might also be a good idea to use iperf for the test. Using that you can test the network separated, instead of disks+raid array+filesystem+samba+network.

  • Ijnrsi
    Ijnrsi Posts: 254  Master Member
    I don't have other brand device, but I test my NAS540 and get the result upload and download around 80MBps, my PC is windows 10. 

    But sometimes when my NAS is working on something or busy, then I can only get 50~60MBps.
    So maybe you can refer Mijzelf's recommandation, check top and try it again at different time.
  • Fredzoul1
    Fredzoul1 Posts: 97  Ally Member
    edited November 2017
    Hello, thanks for all your reply :-)
    I according the Qnap is more powerful and have 8GB ram... I accept difference, but like Mijzelf said, the 540 is surprisly slow for me too...
    It's a good idea to test with the Mijzelf recommandation (top and iperf), thanks for your idea, I make this control tonight or tomorrow and post info/feedback here after :-)
    Have a good day and thanks for your help and info :-)
  • Fredzoul1
    Fredzoul1 Posts: 97  Ally Member
    edited November 2017
    Hi, iperf3 won't work, I think security rules in my computer, I have to check but this week-end...
    Here result of a top command on my NAS540, anything wrong or anything to explain the slow transfert rate with this ?
    - I precise Transmission is started, but no download/upload at this time
    - I have web server for private use (wiki and owncloud), but no traffic from external as I know at this time
    - Darkstat won't use many ressource as I know, just ?
    - FTPS is active, but no download at this time, I'm the only user with access to this NAS
    - RAID 5 is ok, no degraded mode !
    - Tweak active to stop download zcloud and cron shutdown with rules IP ping

    Thanks you for your advice :-)


  • Mijzelf
    Mijzelf Posts: 2,213
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    The whole list of processes look quite normal to me, including their CPU load. But there must be something invisible going on. A 'Load average' of 2.39 is wrong. 
    The number roughly means 'the average number of threads waiting for cpu time'. On a single core machine that should not exceed 1, and on a dual core it should not exceed 2.
    My first idea is that there are a huge number of interrupts. Both ksoftirqd threads are not very active, but maybe it's about interrupts which can not be deferred?
    Have a look at (the changes in) /proc/interrupts

    cd /tmp
    cp /proc/interrupts . ; sleep 1 ; diff /proc/interrupts interrupts

    gives you the changes in one second. (Maybe there is a more easy way, I'm eager to learn.)

    (Does anybody know the equivalent of [code][/code] on this strange forum?)
  • Fredzoul1
    Fredzoul1 Posts: 97  Ally Member
    Hi Mijzelf,
    Result of your command (no problem for me to use terminal).
    The command is sending in same time a make a LAN speed test transfert : 
    I see the number of rescheduling interrupt increases if a resend the command several times.
    The raid exist from 2014-2015, when the FW was 5.04, if it's important to know :-)
    Today the load average is approximately 1.26 during a test, I restart the nas today. But transfer rate don't change.
    Thanks you for your reply

  • Mijzelf
    Mijzelf Posts: 2,213
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    Sorry, can't gather much from that.

    You have 2 boxes showing the same behaviour? And the throughput is about half of the network maximum. I wonder if it could be an MTU size problem. Can you look at the MTU sizes of your QNAP and ZyXEL boxes? And possibly also your PC? here is some information about how to read it on various OS'ses.

    About iperf, how about using your QNAP? You can measure disks+raid+filesystem using dd

    dd if=/dev/zero of=/i-data/sysvol/bigfile bs=1M count=1k

    Have you tried the other network port? (I don't expect much of this, if you have 2 boxes showing the same issue. But it won't hurt.)
  • Fredzoul1
    Fredzoul1 Posts: 97  Ally Member
    edited December 2017
    Hi
    The MTU is 1500 on PC and the 3 qnap, for me it's ok
    Here is the result of NAS540 (1) :

    The second NAS540 (2)


    And here the result of the qnap :


    It's a big difference, for the same network, câble, and hdd in all NAS...
    For the test I use physically the same port in the switch, and the same cable physically...

    The 2 NAS540 are buyed in 2015, and seem to be construct on the same serie if I compare the SN, because buyed in same time (approximatly 2 week).

    Thanks for your reply and your help mijzelf
    Good week-end :-)

Consumer Product Help Center