Enabling AirPrint and Apple Remote on ZyXEL AMG1302-T11C

NigelP
NigelP Posts: 1  Freshman Member
edited December 2017 in Smart Home Product
I had issues with
  • Apple AirPrint on my Canon TS8051 Printer
  • Using the Apple Remote App to control my AppleTV
over wireless connection via my ZyXEL AMG1302-T11C router.  I could not find much help via Google.

After changing multicast settings on the router AirPrint and Remote now work correctly

Change 1 - Network Settings --> Home Networking
  • Multicast - Select IGMP v1/IGMP v2/ IGMP v3 from the drop down
  • IGMP Snooping - Set to Disabled
Change 2 - Network Settings --> Wireless
  • Enhanced Multicast Forwarding -  Set to Enabled
I hope this will help anyone else struggling with AirPrint or the Apple Remote App

Screenshots below for clarity.



#CPE_December
«1

Comments

  • Orcm
    Orcm Posts: 2  Freshman Member
    Wow, this information is helpful to me, thank you.
  • Magicmerly
    Magicmerly Posts: 4  Freshman Member
    Thank you so so much for this, why this is not enabled by default when ApplePrint uses this is beyond me but this as worked a treat, thank you.
  • Magicmerly
    Magicmerly Posts: 4  Freshman Member
    Actually, all may not be as well as it seems. I have 3 Apple products, 1 iphone and 2 ipads. One of the Ipads connected first time no problems at all and the printer can be seen when you go to print but it can no longer be picked up as an air printer by any of the units... weird
  • steviejay
    steviejay Posts: 4  Freshman Member
    What happens when your router doesn't have the Multicast setting?


  • steviejay
    steviejay Posts: 4  Freshman Member
    I got hold of an AMG1302-T10B that I had lying around. All working by following these steps and restarting the printer.
  • steviejay
    steviejay Posts: 4  Freshman Member
    But it isn't maintained when the printer sleeps. I can still print from the laptop using WiFi and the EWS is still accessible, just iDevices say 'No AirPrinter found'. IPP and AirPrint are enabled on the printer (Samsung M2070W) and the firmware is current.
  • steviejay
    steviejay Posts: 4  Freshman Member
    edited July 2018
    I have it working once on restart of the printer.
  • AAAAL
    AAAAL Posts: 125  Ally Member

    Hi steviejay,

    According to your description, I know that you cannot find your wifi printer (Samsung M2070W) when it is in sleep mode, right ? It just disappears in your iDevices, your laptop is available in this ? May I know which is your idevices represent ? (the iphone, ipad etc) 

    Want to know if we wake up the printer at this time, it will be found or not ?

  • TrapperJ
    TrapperJ Posts: 1  Freshman Member
    This is a great help. Since we switched to a new ISP (Post Office) four months ago and got a new Zyxel AMG1302-T11C router, we've been unable to print from any Apple devices to our Canon printer. I followed Nigel P's steps above and am now finally able to print! Thanks Nigel :)

    However, just like steviejay above, my Router Admin screens didn't have a dropdown for Multicast on the Network Setting > Home Networking screen. Instead, on my version, the Multicast field is hidden away at Network Setting > Broadband > Internet Connection > then scroll down and click on 'Advanced Setup' > RIP & Multicast Setup > Multicast and choose IGMP v1 / IGMP v2 / IGMP v3. (But the IGMP Snooping option is still at Network Setting > Home Networking, as shown on Nigel's screenshot above.)
  • Harmony
    Harmony Posts: 1
    Ive done all of the above having switched to Post Office Broadband and my AirPrint still does not work. Any other suggestions? Epson XP645 and Apple AirPrint